Well, while I waited for more help/thoughts on the matter, I happened to have another machine with Jaunty 9.04 that I thought I'd give a try
 I consolidated the install down with the "apt-get" commands at the bottom, and matplotlib failed on the new machine as well (but took longer to fail possibly because the other machine had already compiled everything up to the failing point).  This "new" machine is Intel-based, whereas the other one was AMD-based.  Similar error message:
[code]
<snip>
In file included from /usr/include/c++/4.3/ext/hash_map:64,
                 from ./CXX/Extensions.hxx:68,
                 from src/_backend_agg.h:8,
                 from src/_tkagg.cpp:18:
/usr/include/c++/4.3/backward/backward_warning.h:33:2: warning: #warning This file includes at least one deprecated or antiquated header which may be removed without further notice at a future date. Please use a non-deprecated interface with equivalent functionality instead. For a listing of replacement headers and interfaces, consult the file backward_warning.h. To disable this warning use -Wno-deprecated.
g++ -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions build/temp.linux-i686-2.6/src/agg_py_transforms.o build/temp.linux-i686-2.6/src/_tkagg.o build/temp.linux-i686-2.6/CXX/cxx_extensions.o build/temp.linux-i686-2.6/CXX/IndirectPythonInterface.o build/temp.linux-i686-2.6/CXX/cxxsupport.o build/temp.linux-i686-2.6/CXX/cxxextensions.o -L/usr/local/lib -L/usr/local/lib -ltk8.5 -ltcl8.5 -lstdc++ -lm -lfreetype -lz -lstdc++ -lm -o build/lib.linux-i686-2.6/matplotlib/backends/_tkagg.so
/usr/bin/ld: cannot find -ltk8.5
collect2: ld returned 1 exit status
error: command 'g++' failed with exit status 1
[/code]


<"OLD MACHINE" response>
[code]
BUILDING MATPLOTLIB                                                        
            matplotlib: 0.99.1.1                                           
                python: 2.6.2 (release26-maint, Apr 19 2009, 01:56:41)  [GCC
                        4.3.3]                                             
              platform: linux2                                             

REQUIRED DEPENDENCIES
                 numpy: 1.2.1
             freetype2: 9.20.3

OPTIONAL BACKEND DEPENDENCIES
                libpng: 1.2.27
               Tkinter: Tkinter: 70220, Tk: 8.5, Tcl: 8.5
              wxPython: 2.8.9.1                         
                        * WxAgg extension not required for wxPython >= 2.8
            pkg-config: looking for pygtk-2.0 gtk+-2.0                   
                        * Package pygtk-2.0 was not found in the pkg-config
                        * search path. Perhaps you should add the directory
                        * containing `pygtk-2.0.pc' to the PKG_CONFIG_PATH
                        * environment variable No package 'pygtk-2.0' found
                        * Package gtk+-2.0 was not found in the pkg-config
                        * search path. Perhaps you should add the directory
                        * containing `gtk+-2.0.pc' to the PKG_CONFIG_PATH 
                        * environment variable No package 'gtk+-2.0' found
                        * You may need to install 'dev' package(s) to     
                        * provide header files.                           
                  Gtk+: no                                                
                        * Could not find Gtk+ headers in any of           
                        * '/usr/local/include', '/usr/include', '.'       
       Mac OS X native: no
                    Qt: no
                   Qt4: no
                 Cairo: 1.4.12

OPTIONAL DATE/TIMEZONE DEPENDENCIES
              datetime: present, version unknown
              dateutil: matplotlib will provide
                  pytz: matplotlib will provide
adding pytz

OPTIONAL USETEX DEPENDENCIES
                dvipng: 1.11
           ghostscript: 8.64
                 latex: 3.141592
               pdftops: 0.10.5

[Edit setup.cfg to suppress the above messages]
============================================================================
pymods ['pylab']
packages ['matplotlib', 'matplotlib.backends', 'matplotlib.projections', 'mpl_toolkits', 'mpl_toolkits.mplot3d', 'mpl_toolkits.axes_grid', 'matplotlib.sphinxext', 'matplotlib.numerix', 'matplotlib.numerix.mlab', 'matplotlib.numerix.ma', 'matplotlib.numerix.linear_algebra', 'matplotlib.numerix.random_array', 'matplotlib.numerix.fft', 'matplotlib.delaunay', 'pytz', 'dateutil','dateutil/zoneinfo']
running build
running build_py
copying lib/matplotlib/mpl-data/matplotlibrc -> build/lib.linux-i686-2.6/matplotlib/mpl-data
copying lib/matplotlib/mpl-data/matplotlib.conf -> build/lib.linux-i686-2.6/matplotlib/mpl-data
running build_ext
building 'matplotlib.backends._tkagg' extension
g++ -pthread -shared -Wl,-O1 -Wl,-Bsymbolic-functions build/temp.linux-i686-2.6/src/agg_py_transforms.o build/temp.linux-i686-2.6/src/_tkagg.o build/temp.linux-i686-2.6/CXX/cxx_extensions.o build/temp.linux-i686-2.6/CXX/cxxsupport.o build/temp.linux-i686-2.6/CXX/IndirectPythonInterface.o build/temp.linux-i686-2.6/CXX/cxxextensions.o -L/usr/local/lib -L/usr/local/lib -ltk8.5 -ltcl8.5 -lstdc++ -lm -lfreetype -lz -lstdc++ -lm -o build/lib.linux-i686-2.6/matplotlib/backends/_tkagg.so
/usr/bin/ld: cannot find -ltk8.5
collect2: ld returned 1 exit status
error: command 'g++' failed with exit status 1
[/code]

Consolidated library/dependency install command:
[code]

sudo apt-get install libblas-dev gfortran liblapack-dev python-symeig libfreetype6 libfreetype6-dev tk dvipng python-qt4 python-qt4-common python-tk python-wxgtk2.8 python-wxaddons python-wxtools wx-common wx2.8-headers libwxbase2.8-0 libwxbase2.8-dev libwxgtk2.8-0 libwxgtk2.8-dev tcl8.5-dev tk-dev gfortran-multilib

for Intel:
sudo apt-get install libatlas-sse2-dev libatlas3gf-sse2
or for AMD:
sudo apt-get install libatlas-3dnow-dev libatlas3gf-3dnow

[/code]
Kurt