Since the upgrade to 1.1 my py2exe distribution needs to include Tkinter, Tkconstants and matplotlib.backends.backend_tkagg (which I don't need, but take a lot of place)

if Tkinter is not included, since 1.1 upgrade, I obtain the messages below when distribution is executed :

Traceback (most recent call last):
  File "shyreg.py", line 33, in <module>
  File "matplotlib\pyplot.pyo", line 95, in <module>
  File "matplotlib\backends\__init__.pyo", line 25, in pylab_setup
  File "matplotlib\backends\backend_tkagg.pyo", line 8, in <module>
ImportError: No module named Tkinter

Traceback (most recent call last):
  File "shyreg.py", line 33, in <module>
  File "matplotlib\pyplot.pyo", line 95, in <module>
  File "matplotlib\backends\__init__.pyo", line 25, in pylab_setup
  File "matplotlib\backends\backend_tkagg.pyo", line 8, in <module>
  File "Tkinter.pyo", line 43, in <module>
ImportError: No module named Tkconstants

Traceback (most recent call last):
  File "shyreg.py", line 33, in <module>
  File "matplotlib\pyplot.pyo", line 95, in <module>
  File "matplotlib\backends\__init__.pyo", line 25, in pylab_setup
ImportError: No module named backend_tkagg


Any advise to reduce the needed modules to minimum ?

Loc