Hi,

-my operating system is :
Linux fede 2.6.32-34-generic #77-Ubuntu SMP Tue Sep 13 19:40:53 UTC 2011 i686 GNU/Linux

-matplotlib version
0.99.1.1

 - I obtained the matplotlib from Sourceforge site
 
- my problem is the following:

>>> from mpl_toolkits.basemap import Basemap
 
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.6/dist-packages/mpl_toolkits/basemap/__init__.py", line 31, in <module>
    from mpl_toolkits.axes_grid1 import make_axes_locatable
  File "/usr/local/lib/python2.6/dist-packages/mpl_toolkits/axes_grid1/__init__.py", line 2, in <module>
    from axes_divider import Divider, SubplotDivider, LocatableAxes, \
  File "/usr/local/lib/python2.6/dist-packages/mpl_toolkits/axes_grid1/axes_divider.py", line 343, in <module>
    from matplotlib.gridspec import SubplotSpec, GridSpec
ImportError: No module named gridspec

I've  just installed basemap- 1.0.2   from Sourceforge site.

Waiting for an answer,
Thanks,

Federico