I believe your problem is because your Numeric and numarray packages are not in the same directory as your matplotlib.  your matplotlib is in /usr/local/lib and your numeric packages are in /usr/lib/. 

if you install your packages all the same place, either /usr/ or /usr/local, then it should work.  otherwise, there is some environment variable you can set to tell everything where to look.  or the ugly way is to just symlink what you need into the appropriate directories.

good luck.