Hi,

I'm having trouble with my built-from-source installation of matplotlib on Snow Leopard  (I also tried installing from the .dmg file, but that install failed -- see below for details).

I downloaded:
  matplotlib-1.0.0.tar.gz

and then built and installed:
> tar xvzf matplotlib-1.0.0.tar.gz
> cd matplotlib-1.0.0
> python setup.py build
> python setup.py install

Then tried using pylab:
> cd
> python
Python 2.6.1 (r261:67515, Feb 11 2010, 00:51:29) 
[GCC 4.2.1 (Apple Inc. build 5646)] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import pylab
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/Library/Python/2.6/site-packages/pylab.py", line 1, in <module>
    from matplotlib.pylab import *
  File "/Library/Python/2.6/site-packages/matplotlib/pylab.py", line 216, in <module>
    from matplotlib import mpl  # pulls in most modules
  File "/Library/Python/2.6/site-packages/matplotlib/mpl.py", line 2, in <module>
    from matplotlib import axis
  File "/Library/Python/2.6/site-packages/matplotlib/axis.py", line 10, in <module>
    import matplotlib.font_manager as font_manager
  File "/Library/Python/2.6/site-packages/matplotlib/font_manager.py", line 52, in <module>
    from matplotlib import ft2font
ImportError: dlopen(/Library/Python/2.6/site-packages/matplotlib/ft2font.so, 2): Symbol not found: _FT_Attach_File
  Referenced from: /Library/Python/2.6/site-packages/matplotlib/ft2font.so
  Expected in: flat namespace
 in /Library/Python/2.6/site-packages/matplotlib/ft2font.so

I've seen both of these problems listed elsewhere, but no solution posted:
  http://www.mailinglistarchive.com/html/matplotlib-users@lists.sourceforge.net/2010-09/msg00091.html

Any help is greatly appreciated.

Here's information on my environment: 
  
Mac OS X 10.6.4
> uname -a
Darwin My-MacBook-Pro.local 10.4.0 Darwin Kernel Version 10.4.0: Fri Apr 23 18:28:53 PDT 2010; root:xnu-1504.7.4~1/RELEASE_I386 i386

I was building from source because I was not able to install from the DMG installer (matplotlib-1.0.0-python.org-py2.6-macosx10.4.dmg).  When I tried the .dmg installer, I got the following message:
   matplotlib 1.0.0-r0 can't be installed on this disk.
   matplotlib requires System Python 2.6 to install

Thanks for your help,
James