On Mon, Mar 24, 2008 at 10:01 AM, Zachary Pincus <zachary.pincus@yale.edu> wrote:
> Zachary Pincus wrote:
>
>>> Can you tell me where you specified the -Os option to gcc to escape
>>> the problem?
>>
>> So the compile that command that failed is printed right above the
>> error message it generated. (The long line that starts  with
>> 'gcc' ...). I just copied this command, edited the -O3 to an -Os, and
>> pasted that command-line back into the terminal. Total low-tech hack,
>> as I didn't want to much with the setup.py file to fix compile flags
>> on a per-file basis.
>>
>> After that file is compiled manually, you can re-run 'python setup.py
>> build', and it will start up at the next step after the error.
>>
>> I got the same error in another step, which was a bit trickier to
>> fix,
>> because for some reason, src/_image.cpp gets copied to src/image.cpp
>> on a temporary basis, and then compiled. (I presume the file isn't
>> also modified?) But after the compile errors out, the copy is
>> deleted,
>> so just pasting in the offending gcc command doesn't work. So I had
>> to
>> manually copy src/_image.cpp to scr/image.cpp, and then paste in the
>> modified gcc command.
>>
>> Ugh! I'd really love some help reducing this to a test case that I
>> can
>> send to Apple.
>
> I've got the same error(s) in the same situation (10.5.2). I haven't
> seen it any other context nor have had any success in reducing to a
> test
> case, alas. Could this have to do with picking up libraries (from fink
> or elsewhere) and/or different compiler versions? I've got XCode 3 and
> gcc 4.0. (I've actually got the apple 4.2 preview release as well but
> that craps out even earlier, I assume due to library version
> mismatches...)

I'm pretty sure what I'm seeing isn't from Fink or other library
versions -- this was on a pretty clean 10.5 install. I'm using a
custom-built Python 2.5.2 instead of Apple's, so that required
installing a new version of readline, but other than that, the system
is plain vanilla.

Has nobody else built matplotlib from source on 10.5.2 lately?

I tried it after seeing your message.  Indeed I got the same internal gcc failure.  This is a compiler problem the with the gcc on 10.5.2 (and 10.5.1 I think).  I found the same error message on many google hits outside of matplotlib.  Your suggestion of compiling with -Os for the two problem files worked fine for me.

- Charlie