I noticed that this release candidate will always skip the Mac OS X backend,
as the .check() method of BackendMacOSX in setupext.py returns None. Adding
    return "darwin"
or some other string solves the issue.
Also, if I am not mistaken, the files under lib/matplotlib/backends/Matplotlib.nib (as returned by the get_package_data() method of BackendMacOSX in setupext.py) are needed by the cocoaagg backend, not by the MacOSX backend.

Best,
-Michiel.
_______________________________________________