Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#904 configure parametrs; bug in docs?

Stable_(v3.10.x)
closed-fixed
None
5
2014-07-09
2013-05-02
Stepan Kasal
No

Hello,
following the recommendation from section 8.2 from atlas_install, I tried:

../configure -b 64 -D c -DPentiumCPS=2100 -Fa alg --shared [...]

but the configure script picked the --shared as its own parameter, leading to:

./xconfig [...] -b 64 -D c -DPentiumCPS=2100 -Fa alg -D c -DATL_DYLIBS

and xconfig complained.

1) I'd like to ask for help: I have resolved this by removing "-Fa alg" from the configure line, is that OK? (I'm actually compiling by x86_64-mingw64 in cygwin, so I also have inserted "-Si archdef 0" after the "-b 64".)

2) It seems to be typo in atlas_install, so I report it.

Thank you very much for this library, it looks really interesting. I'm looking forward that it'll make our R faster, and your approach seems much more stable in time than the various products tailored to the particular processors of a particular era. Thanks again.

Discussion

  • Indeed, omitting -Fa alg is the correct fix, and you did indeed find an error in atlas_install! Many thanks for reporting it,

    Clint

     
    • status: open --> open-fixed
    • assigned_to: R. Clint Whaley
     
  • I have fixed in basefiles, will be fixed in next release.

     
  • Stepan Kasal
    Stepan Kasal
    2013-05-02

    That was really quick, thank you very much!

    Stepan Kasal

     
    • status: open-fixed --> closed-fixed