Dear Dustin,

>I notice you have been doing work on the 1.2.x branch for mantis,

I focus bug fixes and improvements on 1.2 branch because that's what I use; however, unless I made a mistake, all of the changes I've made to 1.2.x branch, have been also committed to master (1.3) branch.

> but the next branch is not getting those changes.

The 'next' branch is a work-in-progress that may or may not be merged into (or replace) master at some point, you probably should not be using that or be concerned about it for now.

> Do you know anything about version 1.3.0?  It looks like it hasn't been updated in a long time. Is it dead?

What makes you say that 1.3 has not been updated ? Nightly builds are published every day on http://www.mantisbt.org/builds/

If you refer to sourceforge downloads, we only publish "official" releases there, i.e. alpha / release candidates. 1.3 is nowhere near that yet...

It is not dead, but at the moment, there is no clear plan or agreement within the dev team on what the next release should be and when it could go live. Incidentally, that's also one of the reasons why I focus more on 1.2.

> Should I switch my server from 1.3.0-dev to 1.2.x if I want support in the future?

I don't think there is any reason to downgrade from 1.3.0-dev to 1.2.x
Both 1.2 and 1.3 dev are supported. If you experience any issue on either, just report them on our bug tracker and someone will have a look as time allows.

> Is it even possible to switch from 1.3.0-dev to 1.2.x?)

There is no downgrade path so you may be facing issues (and be on your own) if you tried it .

Damien

PS: copying the mailing list for the record





From:        Dustin Massop <dustin.in.linux@gmail.com>
To:        damien.regad@merckgroup.com
Date:        05.09.2012 00:45
Subject:        mantis 1.2.x vs 1.3.0-dev




Hi,

I notice you have been doing work on the 1.2.x branch for mantis, but the next branch is not getting those changes. Do you know anything about version 1.3.0? It looks like it hasn't been updated in a long time. Is it dead? Should I switch my server from 1.3.0-dev to 1.2.x if I want support in the future? (Is it even possible to switch from 1.3.0-dev to 1.2.x?)

Thanks,

--

Dustin Massop


This message and any attachment are confidential and may be privileged or otherwise protected from disclosure. If you are not the intended recipient, you must not copy this message or attachment or disclose the contents to any other person. If you have received this transmission in error, please notify the sender immediately and delete the message and any attachment from your system. Merck KGaA, Darmstadt, Germany and any of its subsidiaries do not accept liability for any omissions or errors in this message which may arise as a result of E-Mail-transmission or for damages resulting from any unauthorized changes of the content of this message and any attachment thereto. Merck KGaA, Darmstadt, Germany and any of its subsidiaries do not guarantee that this message is free of viruses and does not accept liability for any damages caused by any virus transmitted therewith.

Click http://www.merckgroup.com/disclaimer to access the German, French, Spanish and Portuguese versions of this disclaimer.