Well, I fell kind of silly since I found issue #1 on the management page, plain as day.
However, I also have three more issues to resolve:
3) Escape characters are incorrect for SQL Server
4) Can't filter -- appears to work (i.e. no errors and page refreshed), but just doesn't filter
5) Can't sort -- also appears to work, but doesn't sort

From: Nicole Castle
Sent: Thursday, July 07, 2005 2:18 PM
To: 'mantisbt-help@lists.sourceforge.net'
Subject: Application error #1100 Issue ___ not found

I have Mantis 0.19.2 up and running with SQL Server 2000.  LOTS of manual DB changes, but I seem to have shaken out most if not all of my typos.
All seems to be working properly (so far) except 2 issues:
1) When reporting an issue, the "Category" valuelist is missing its items.  Where can I find where those values are enumerated so I can manually add them?
2) After reporting an issue, it appears in the View Issue list.  However, when you click on the ID# I get an error:
Issue 1 not found.
Please use the "Back" button in your web browser to return to the previous page. There you can correct whatever problems were identified in this error or select another action. You can also click an option from the menu bar to go directly to a new section.
I can manually select the ID # from the mantis_bug_table and all fields look good.  I manually updated the Category field to specify "Bugs" and tried again, but I get the same error.  I can, however, update the bug if I select the checkbox and Update Status.
Other than several users I have set up, the project and the records entered into the mantis_upgrade_table, the only data in the database is:
1 record in mantis_bug_table
2 in the mantis_bug_history_table
1 in the mantis_bug_text_table
The foreign keys match up.  I am assuming perhaps an insert into another table silently failed?  Reporting another issue, I also get a success message on the report, but cannot view the file.
Any assistance appreciated.
Nicole Castle
Developer, Escrowdesk, LLC