Hi Naseer I had same problem few weeks ago but I changed following lines and everything working fine now

config_defaults_inc.php  file.

 

1-              $g_hostname  = 'localhost';

                 $g_db_username= 'root';

                 $g_db_password= 'password';

                 $g_database_name= 'bugtracker';

 

2-             $g_administrator_email =’mymail@company.in’;

                 $g_webmaster_email    = ' mymail@company.in’;

 

3-              $g_from_email                  = ' mymail@company.in ';

 

4-              $g_enable_email_notification = ON;

 

5-              $g_email_receive_own              = ON;

 

6-              $g_phpMailer_method               = 2;  //this one very important

 

7-               $g_smtp_host                = 'smtp.company. in';

 

 

From: naseer.khan@wipro.com [mailto:naseer.khan@wipro.com]
Sent: Wednesday, April 28, 2010 12:41 AM
To: mantisbt-help@lists.sourceforge.net
Subject: [mantisbt-help] Mantis not sending emails

 

Hi,

 

I have installed Mantis Version 1.2.0 on a Windows XP machine, but I am not getting any mails from Mantis.

 

My setup details:

Mantis Version: 1.2.0
Apache Version: 2.2
SQL Version: 5.1
PHP Version: 5.2.13

 

Mantis has been installed successfully and we are able to create the user logins and also register bugs in Mantis.

 

The problem is, we are not getting any mails from Mantis on creation of new user account or on registering a new bug. Neither the reset password or lost password features are sending any mails.

 

Don't know where the problem is, and any help towards this will be highly appreciable.

 

My configuration details:
$g_smtp_host='xx.xx.xx.xx'; /* Don't know is this right format */
$g_smtp_connection_mode= 'ssl';
$g_smtp_port = 25;
$g_smtp_username = 'name';
$g_smtp_password = 'password';

 

We have tried all the possible help which we could get from google but not much use.

 

So, pls let us know is we are missing any configuration.

 

Thanks & Regards,
Naseer.