Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

#29 rpm install dependencies for 2.0

closed-fixed
nobody
None
5
2012-05-06
2012-03-21
KQ1
No

$ rpm -i makepp-2.0.rpm
error: Failed dependencies:
perl(Mpp::FileOpt) is needed by makepp-2.0-2.noarch
perl(Mpp::Utils) is needed by makepp-2.0-2.noarch
$ cpan -i Mpp::FileOpt Mpp::Utils
CPAN: Storable loaded ok (v2.15)
Reading '.../.cpan/Metadata'
Database was generated on Wed, 21 Mar 2012 12:12:45 GMT
Warning: Cannot install Mpp::FileOpt, don't know what it is.
Try the command

i /Mpp::FileOpt/

to find objects with matching identifiers.
CPAN: Time::HiRes loaded ok (v1.9715)
Warning: Cannot install Mpp::Utils, don't know what it is.
Try the command

i /Mpp::Utils/

to find objects with matching identifiers.
$ cat /etc/redhat-release
CentOS release 5.3 (Final)
$

Discussion

  • Hmm, I can't say anything about this. The rpm is generated by the tool alien from the deb, which works on Ubuntu. I don't have root access to an rpm distro, so I can't try it. Quite a few release candidate rpms were downloaded without any complaints, so I wonder if they gave up or this is a specific problem of your system.

    The "dependencies" it complains about are part of the distribution, not something to get separately from CPAN. So it seems to be getting something wrong here!

     
    • status: open --> closed
     
  • I have worked around a bug in rpmbuild and uploaded a fixed but otherwise identical package.

     
    • status: closed --> closed-fixed