#666 Problem starting MailManager2.1.0 under Zope 2.9.3

2.1.0
closed-invalid
Installers (6)
5
2006-10-16
2006-10-06
senacle
No

2006-10-06T21:54:40 ERROR Zope Couldn't install MailManager
Traceback (most recent call last):
File "E:\Zope-2.9.3\lib\python\OFS\Application.py",
line 762, in install_product
global_dict, global_dict, silly)
File
"E:\Zope-Instance2.9.3\Products\MailManager\__init__.py",
line 10, in ?
import MailManager, MMUserFolder
File
"E:\Zope-Instance2.9.3\Products\MailManager\MailManager.py",
line 71, in ?
import mx.DateTime
File
"E:\Zope-2.9.3\bin\lib\site-packages\mx\DateTime\__init__.py",
line 40, in ?
class modinit:
File
"E:\Zope-2.9.3\bin\lib\site-packages\mx\DateTime\__init__.py",
line 50, in modinit
_DT)
File "E:\Zope-2.9.3\bin\lib\copy_reg.py", line 16, in
pickle
raise TypeError("copy_reg is not intended for use
with classes")
TypeError: copy_reg is not intended for use with classes

Discussion

  • senacle
    senacle
    2006-10-06

    • assigned_to: nobody --> kevca
     
  • Kevin Campbell
    Kevin Campbell
    2006-10-16

    • status: open --> closed-invalid
     
  • Kevin Campbell
    Kevin Campbell
    2006-10-16

    Logged In: YES
    user_id=1241761

    Please note that Zope 2.9 is not currently supported.
    MailManager 2.2 may support zope 2.9.

     
  • senacle
    senacle
    2006-10-16

    Logged In: YES
    user_id=1533089

    When do you think that MailManager 2.2 will be released ?

     
  • Kevin Campbell
    Kevin Campbell
    2006-10-25

    Logged In: YES
    user_id=1241761

    It appears the issue here is in mx.DateTime and is entirely
    unrelated to MailManager? Have you tried replacing your
    mx.DateTime library?

    MailManager 2.2 will support Zope 2.9, as that is now an
    internal development goal. Having tested this, it appears
    that 2.1 may work on Zope 2.9 also, but will require python
    2.4. The final release of 2.2 may not be until the new year.