#880 Embedded images using Content-ID are lost.

2.1 (stable)
closed-invalid
nobody
5
2004-05-27
2004-05-26
Stuart Donaldson
No

Sending e-mail with an embedded image that includes the
image as a part of the message identified by Content-ID
does not work.

When sending a message to the list with an embedded
image, the message arrives and is archived where the
image intact. The MIME headers for the message
reference a <img src="cid:xxx"> and there is a header
on the mime component for "Content-ID: <xxx>"

However the message that gets delivered to the list
members does not include the Content-ID. The embedded
image is still included in the message, but is not
displayed because of the missing header.

Version 2.1.4

Discussion

    • status: open --> closed
     
  • Logged In: YES
    user_id=326269

    After digging further to try and solve the problem, I found
    that it was a result of an old version of the Anomy
    Sanitizer that IT has running on the mail server. The
    Sanitizer was stripping the Content-ID field.

    Sorry for the false alarm.

     
    • status: closed --> closed-invalid
     
  • Logged In: YES
    user_id=326269

    BTW - marked the bug as closed so it would stick around in
    case someone else has a similar problem, even though it is
    not a bug with Mailman. I have no problems with someone
    deleting this bug if you don't want it in your list.