It doesn't look like a hardware problem : I tried with four different cards in the two pcmcia slots of the laptop and the problem is exactly the same.
A dmesg after loading the module only returns : ath_hal: 0.9.14.9 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413).

On Thu, Mar 27, 2008 at 4:52 PM, Pavel Roskin <proski@gnu.org> wrote:
On Thu, 2008-03-27 at 16:44 +0100, Julien Herzen wrote:
> Hi all,
>
> I'm trying to install an old version of madwifi (r1417, 20060128) on
> three laptops running Debian sarge with the kernel 2.4.27-2-386. On
> two of them, all is ok, the compilation, the installation are ok, and
> when I run modprobe ath_pci, all is fine and an interface ath0 is
> created.
> On the third one, the compilation, installation and loading of the
> modules are ok, but no interface ath0 is created (iwconfig returns
> just : lo : no wireless extension), despite the fact that the modules
> were apparently loaded successfully (lsmod | grep ath shows ath_pci,
> ath_rate_sample, wlan and ath_hal, which exactly the same result on
> the two laptops that have an interface ath0 created).

That's what you would see if the hardware is not present or doesn't
function correctly.  See kernel messages using the "dmesg" command.

--
Regards,
Pavel Roskin