Hello Everyone,


I am having the issue Madwifi driver + AR2413 chipset transmitting higher
 power at lower band(<2.4012 Ghz) when there are no AP. Verified this by
 connecting spectrum analyzer and seeing the transmitted power.

 I am using the chipset AR2413 and madwifi driver svn revision 4022 and linux 2.6.24.3. More
 details of

 lspci
 03:0f.0 Ethernet controller: Atheros Communications, Inc. AR5005G
 802.11abg NIC (rev 01)
        Subsystem: Atheros Communications, Inc. Compex Wireless 802.11 b/g
 MiniPCI Adapter, Rev A1 [WLM54G]
        Flags: bus master, medium devsel, latency 96, IRQ 20
        Memory at dfce0000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 4

-----------------------

 dmesg when the module is loaded
 MadWifi: ath_attach: Switching rfkill capability off.
 wifi0: Atheros AR2413 chip found (MAC 7.8, PHY 2112A 4.5, Radio 5.6)
 ath_pci: wifi0: Atheros 2413: mem=0xdfce0000, irq=20


 -------------------------

 I am using wpa_supplicant, the wpa_supplicant.conf settings are
 ctrl_interface=/var/run
 ctrl_interface_group=<groupname>
 update_config=1

 ----------------------------
 Since this is operated in germany, I am setting the regdomain to 0x37 in
 EEPROM of chip using ath_info utility
 ath_info -f -w dfce0000 regdomain=0x37

 Then loading the driver using countrycode settings
 modprobe ath_pci countrycode=276

 strating the wpa_supplicant
 ----------------------------------
 Note there are on access point available and when we measure the transmit
 power it shows 10dbm higher in lower band(<channel1(2.4012Ghz), this is
 violating the german ETSI regulations . As soon as access point/ssid
 becomes available the power level goes down and is within germany
 regulation.

 When does the maxtxpower gets set ? I am not sure if the driver is
 initializing all the values when I load the madwifi driver with germany
 country-code or it does later when it find a AP during scan. Any solution
 to this would help greatly, this blocking from product being passed for
 certification.



When is the maxtxpower set? As we see the txpower go down when it finds any AP otherwise it very high at lower band(<2.4012Ghz)



--
Thanks and Regards,
Soumya