Hi developers:

 

[Problem]

When I study openCapwap, it requires a PC have a wireless card with Atheros chipset and MadWifi driver installed.

 

And I followed MadWifi 'First Time User' HOWTO until last step Loading the MadWifi Module:

 

modprobe ath_pci

 

After running this command ifconfig doesn't show the additional wireless interface even after I reboot Ubuntu.

 

[Guess]

After I googled and went through MadWifi userdocs,  I think maybe MadWifi do not support AR992X chipsets?

 

And If so, is any workaround?

 

-Environment-

 

[madwifi-0.9.4-current.tar.gz]

 

[Ubuntu 12.04 LTS Desktop]

Linux test-HP-Z220-SFF-Workstation 3.2.0-34-generic-pae #53-Ubuntu SMP Thu Nov 15 11:11:12 UTC 2012 i686 i686 i386 GNU/Linux

 

[lspci | grep Network]

00:19.0 Ethernet controller: Intel Corporation 82579LM Gigabit Network Connection (rev 04)

02:00.0 Network controller: Atheros Communications Inc. AR922X Wireless Network Adapter (rev 01)

 

[lsmod | grep ath]

ath_pci                93548  0

wlan                    197352  1 ath_pci

ath_hal               195796  1 ath_pci

 

[dmesg]

[17310.501082] ath9k 0000:02:00.0: PCI INT A disabled

[17310.501109] ath9k: Driver unloaded

[17340.211357] usbcore: deregistering interface driver ath9k_htc

[17340.211384] ath9k_htc: Driver unloaded

[17795.786750] ath_hal: 0.9.18.0 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)

[17795.789056] wlan: svn r4180 (branch madwifi-0.9.4)

[17795.790003] ath_pci: svn r4180 (branch madwifi-0.9.4)

[18227.499706] ath_pci: driver unloaded

 

--

daqla