Hi,

We are facing BB panic error, which comes when Atheros HAL baseband panics. We are using 9390 radio chip. Below are the prints.

[  583.626238] 
[  583.626241] ==== BB update: BB status=0x02041109, tsf=0x0fdf5719 ====
[  583.634347] ** BB state: wd=1 det=1 rdar=0 rOFDM=1 rCCK=1 tOFDM=4 tCCK=0 agc=2 src=0 **
[  583.642354] ** BB WD cntl: cntl1=0xffff0085 cntl2=0x00000004 **
[  583.648270] ** BB mode: BB_gen_controls=0x000033c0 **
[  583.653317] 
[  583.658455] ==== BB update: done ====
[  583.658457]

These prints are printed in driver when HAL BB Panic interrupt (0x00000400) comes.

For us, these panics only comes on station radio. These panics specifically comes when AP-Station link is encrypted and association happens at HT20 rate (144Mbps). When we are connecting with 54Mbps rate, we haven't seen these panics. Encryption used is 128-bit AES ( CCMP ) encryption. We are not having much data transfer.

On station radio box, we have 2 other radios operating in HT20 mode, configured as AP. They are only beaconing and no clients are associated to them.

Such 400 BB panics comes every 30 minutes. We are monitoring chip temperature also. Every 30 minutes it reaches a spike of 75 degree Centigrade(may be more). At that time STA gets "beacon miss" of connected AP momentarily and re-associates within 5 seconds. Temperature also goes down to 55 degree Centigrade within 5 seconds of association break.

Can you please suggest what could be the reason for these bb panics?

Regards,
Deep