On Thu, Aug 26, 2010 at 9:36 AM, Ismaeel Abu Amsha <just4ism@hotmail.com> wrote:


i read that TL-WN550G/TL-WN551G

Working fine with MadWiFi SVN 20080109 under Ubuntu server 7.10. Running in master mode without any problems.


but when tried to set it using under ubuntu 8.04 server
using madwifi driver

root@samo:~# iwconfig ath0 mode Master
Error for wireless request "Set Mode" (8B06) :
SET failed on device ath0 ; Invalid argument.

when tested it using hostap

root@samo:~# hostapd /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
ioctl[SIOCSIWMODE]: Invalid argument
Could not set interface to master mode!
madwifi driver initialization failed.

are you sure it is working ?

------------------------------------------------------------------------------
Sell apps to millions through the Intel(R) Atom(Tm) Developer Program
Be part of this innovative community and reach millions of netbook users
worldwide. Take advantage of special opportunities to increase revenue and
speed time-to-market. Join now, and jumpstart your future.
http://p.sf.net/sfu/intel-atom-d2d
_______________________________________________
Madwifi-users mailing list
Madwifi-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/madwifi-users


Hi,

Try the following steps to set your card into Master mode:
The interface is ath0

sudo service network-manager stop

sudo wlanconfig ath0 destroy

sudo wlanconfig ath0 create wlandev wifi0 wlanmode ap

sudo iwconfig ath0 essid test # Set the network's essid

sudo iwconfig ath0 channel 1 #Set the channel

sudo ifconfig ath0 up


Hope this helps,
Regards
--
Mohammad