On Fri, Aug 13, 2010 at 9:37 AM, ielix <ielix@hotmail.com> wrote:
Madwifi-users,
 
Im still struggling to load the module.

I have just installed Slackware 13.1 on a samsung r580 with an atheros Ar 9285 card in it.
 
When installing I began by blacklisting the ath9k drivers and rebooting (The card seems to work prefectly using these drivers, however packet injection shows no performance).
 
I then downloaded the latest version of madwifi-ng using svn checkout http://svn.madwifi.org/trunk madwifi-ng.
make and make install complete without errors. However after issuing modprobe ath_pci, wifi0/ath0 are still not listed under ifconfig or iwconfig.

I was advised to rather use insmod with dmesg and this provided the following list of errors.

bash-4.1# insmod ath_pci.ko | dmesg| grep ath

ath_pci: Unknown symbol ieee80211_check_mic
ath_pci: Unknown symbol ieee80211_encap
ath_pci: Unknown symbol ieee80211_input
ath_pci: Unknown symbol ieee80211_ifattach
ath_pci: Unknown symbol _ath_hal_attach
ath_pci: Unknown symbol ieee80211_beacon_update
ath_pci: Unknown symbol ath_hal_process_noisefloor
ath_pci: Unknown symbol ieee80211_find_rxnode
ath_pci: Unknown symbol ieee80211_skb_track
ath_pci: Unknown symbol ieee80211_dev_kfree_skb_list
ath_pci: Unknown symbol ieee80211_ref_node
ath_pci: Unknown symbol ieee80211_vap_setup
ath_pci: Unknown symbol ieee80211_ifdetach
ath_pci: Unknown symbol ieee80211_input_monitor
ath_pci: Unknown symbol ieee80211_dev_kfree_skb
ath_pci: Unknown symbol ieee80211_unref_node
ath_pci: Unknown symbol ath_hal_computetxtime
ath_pci: Unknown symbol ieee80211_crypto_newkey
ath_pci: Unknown symbol ieee80211_crypto_setkey
ath_pci: Unknown symbol ieee80211_dump_pkt
ath_pci: Unknown symbol ieee80211_ioctl_create_vap
ath_pci: Unknown symbol ieee80211_dev_alloc_skb
ath_pci: Unknown symbol ath_hal_mhz2ieee
ath_pci: Unknown symbol ieee80211_stop_running
ath_pci: Unknown symbol ieee80211_cipher_none
ath_pci: Unknown symbol _ath_hal_detach
ath_pci: Unknown symbol ieee80211_crypto_delkey
ath_pci: Unknown symbol ath_debug_global
ath_pci: Unknown symbol ieee80211_skb_untrack
ath_pci: Unknown symbol ieee80211_media_change
ath_pci: Unknown symbol ieee80211_beacon_miss
ath_pci: Unknown symbol ieee80211_beacon_alloc
ath_pci: Unknown symbol ieee80211_iterate_nodes
ath_pci: Unknown symbol ieee80211_vap_attach
ath_pci: Unknown symbol ieee80211_wme_updateparams
ath_pci: Unknown symbol ieee80211_ibss_merge
ath_pci: Unknown symbol ieee80211_mhz2ieee
ath_pci: Unknown symbol ath_hal_probe
ath_pci: Unknown symbol ieee80211_rate_attach
ath_pci: Unknown symbol ath_hal_print_decoded_register
ath_pci: Unknown symbol ieee80211_rate_detach
ath_pci: Unknown symbol ieee80211_send_qosnulldata
ath_pci: Unknown symbol ieee80211_create_vap
ath_pci: Unknown symbol ieee80211_wme_acnames
ath_pci: Unknown symbol ieee80211_input_all
ath_pci: Unknown symbol ieee80211_media_status
ath_pci: Unknown symbol ieee80211_start_running
ath_pci: Unknown symbol ieee80211_vap_detach
ath_pci: Unknown symbol ieee80211_announce
ath_pci: Unknown symbol ieee80211_mark_dfs
ath_pci: Unknown symbol ieee80211_chan2ieee
ath_pci: Unknown symbol ieee80211_state_name
ath_pci: Unknown symbol ath_hal_init_channels
ath_pci: Unknown symbol ieee80211_dturbo_switch
ath_pci: Unknown symbol ieee80211_crypto_encap
ath_pci: Unknown symbol ieee80211_chan2mode
ath_pci: Unknown symbol ieee80211_getrssi
ath_pci: Unknown symbol ieee80211_find_txnode
ath_pci: Unknown symbol ieee80211_cancel_scan
ath_pci: Unknown symbol ath_hal_getwirelessmodes
insmod: error inserting 'ath_pci.ko': -1 Unknown symbol in module

Google let me to several possible solutions but none of them are applicable to Slackware, I am now at something of a loss.

I have tried installing both madwifi and madwifi-ng with the same results, I must admit that I am very new to Linux and I apologize in advance for any fundamental mistakes that I may have made.
 
Once again I will greatly appreciate any help you can provide.

------------------------------------------------------------------------------
This SF.net email is sponsored by

Make an app they can't live without
Enter the BlackBerry Developer Challenge
http://p.sf.net/sfu/RIM-dev2dev
_______________________________________________
Madwifi-users mailing list
Madwifi-users@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/madwifi-users


It looks as though you haven't loaded all the madwifi modules in the proper order.  modprobe will sort out the dependencies and load everything you need, while insmod will not.  Have you applied the patches for AR9285 support?  They are available as attachments to the ticket here: http://madwifi-project.org/ticket/2391

The AR9285 is not supported in trunk yet.  I would guess that once you apply these patches, rebuild, and reinstall, then modprobe should work just fine.