Hi all,

I have recently updated svn madwifi (r3876), cross compiled and loaded madwifi modules on my Intel IXP425 board running OpenWRT kamikaze linux 2.6.26.2.
 
I have noticed that the windows client (STA) frequently disconnects and reconnects (receive ip address offered by dhcp) every 30 secs approximately with AP created using "wlanconfig ath0 create wlandev wifi0 wlanmode ap " or  "wlanconfig ath0 create wlandev wifi0 wlanmode ap -uniquebssid"
root@OS_R01:~# iwconfig
lo        no wireless extensions.
eth0      no wireless extensions.
eth1      no wireless extensions.
wifi0     no wireless extensions.
 
ath0      IEEE 802.11g  ESSID:"OS4_IN"  Nickname:""
          Mode:Master  Frequency:2.437 GHz  Access Point: 00:0B:6B:09:2E:66
          Bit Rate:0 kb/s   Tx-Power:19 dBm   Sensitivity=1/1
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=38/70  Signal level=-58 dBm  Noise level=-96 dBm
          Rx invalid nwid:1125  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 
root@OS_R01:~# tail -f /var/log/messages
Nov 27 09:44:23 OpenWrt dnsmasq[2438]: DHCPREQUEST(ath0) 192.168.3.10 00:16:cf:51:15:03
Nov 27 09:44:23 OpenWrt dnsmasq[2438]: DHCPACK(ath0) 192.168.3.10 00:16:cf:51:15:03 sara
Nov 27 09:45:18 OpenWrt dnsmasq[2438]: DHCPREQUEST(ath0) 192.168.3.10 00:16:cf:51:15:03
Nov 27 09:45:18 OpenWrt dnsmasq[2438]: DHCPACK(ath0) 192.168.3.10 00:16:cf:51:15:03 sara
Nov 27 09:45:53 OpenWrt dnsmasq[2438]: DHCPREQUEST(ath0) 192.168.3.10 00:16:cf:51:15:03
Nov 27 09:45:53 OpenWrt dnsmasq[2438]: DHCPACK(ath0) 192.168.3.10 00:16:cf:51:15:03 sara
 

Is this issue due to cross compilation ? whereas the wifi card AP works fine with prior older revision r3856.

Sara