-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

Update:

I have managed to install these RPMs:
kmod-madwifi-smp.i686                    0.9.0-1.2.6.17_1.2157_ installed
madwifi.i386                             0.9.0-1.lvn5           installed
madwifi-hal-kmdl-2.6.17-1.2157_FC5smp.i6 1:0.9.1-24.rhfc5.at    installed
madwifi-kmdl-2.6.17-1.2157_FC5smp.i686   1:0.9.1-24.rhfc5.at    installed

and have created the ath0 device and it works.


.

s.

LOEWENTHAL Simon wrote:

| Dear all,
|
| I have removed the packages below and tried to install the RPMs once
| more following the instructions found on the madwifi.org page:
| # yum install madwifi madwifi-kmdl-`uname -r`
| This installed these RPMs:
|
|
|   Installing: madwifi-kmdl-2.6.17-1.2157_F #########################
| [1/3]
|   Installing: madwifi-hal-kmdl-2.6.17-1.21 #########################
| [2/3]
|   Installing: madwifi                      #########################
| [3/3]
|
| Installed: madwifi.i386 1:0.9.1-24.rhfc5.at
| madwifi-kmdl-2.6.17-1.2157_FC5smp.i686 1:0.9.1-24.rhfc5.at
| Dependency Installed: madwifi-hal-kmdl-2.6.17-1.2157_FC5smp.i686
| 1:0.9.1-24.rhfc5.at
| Complete!
|
| ...But when I attempt to install madwifi-kmod I get a dependancy
| failure:
|
| Parsing package install arguments
| Resolving Dependencies
| --> Populating transaction set with selected packages. Please wait.
| ---> Package kmod-madwifi.i686 0:0.9.0-1.2.6.17_1.2157_FC5 set to be
| installed
| --> Running transaction check
| --> Processing Dependency: madwifi-kmod-common >= 0.9.0 for package:
| kmod-madwifi
| --> Finished Dependency Resolution
| Error: Missing Dependency: madwifi-kmod-common >= 0.9.0 is needed by
| package kmod-madwifi
|
|  I cannot find madwifi-kmod-common anywhere on the web.
| Could someone please tell me where it is?
|
| Cheers, S.
|
|
|
| LOEWENTHAL Simon wrote:
|
|> Dear all,
|>
|> I apologise for contacting you over such a matter, but so far I am
|> been able to solve the problem, which I expect is a silly newb
|> problem...
|>
|> I installed the RPMs list below, and they created these modules:
|> /lib/modules/2.6.17-1.2157_FC5/updates/net/ath_hal.ko
|> /lib/modules/2.6.17-1.2157_FC5/updates/net/ath_rate_sample.ko
|> /lib/modules/2.6.17-1.2157_FC5/updates/net/ath_pci.ko
|>
|> Current RPMs installed:
|> madwifi.i386                             1:0.9.1-24.rhfc5.at   
|> installed
|> madwifi-hal-kmdl-2.6.17-1.2157_FC5.i686  1:0.9.1-24.rhfc5.at   
|> installed
|> madwifi-kmdl-2.6.17-1.2157_FC5.i686      1:0.9.1-24.rhfc5.at   
|> installed
|>
|>
|> However, I cannot load them.
|> # !mod
|> modprobe ath_hal.ko
|> FATAL: Module ath_hal.ko not found.
|> # modprobe ath_hal
|> FATAL: Module ath_hal not found
|> insmod /lib/modules/2.6.17-1.2157_FC5/updates/net/ath_hal.ko
|> insmod: error inserting
|> '/lib/modules/2.6.17-1.2157_FC5/updates/net/ath_hal.ko': -1 Invalid
|> module format
|>
|> Current kernel is,
|> Linux host1 2.6.17-1.2157_FC5smp #1 SMP Tue Jul 11 23:24:16 EDT 2006
|> i686 i686 i386 GNU/Linux
|>
|> and the card is a
|> Ubiquto SRC 300mW 802.11 a/b/g MMCX card.
|>
|> It have it working with WXP.
|>
|> I would be very grateful if you could explain to me what I am doing
|> wrong.
|>
|> Regards, S.
|
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.4 (GNU/Linux)

iD8DBQFEx9AVADFLpmwodyMRCiAyAJ4tgGKCRAe3c9waaw3gnhp1yDrCRQCfU0yn
h4u4sbamiy0qjXNKWkgWmpE=
=JNIR
-----END PGP SIGNATURE-----