FG on OS X.6 does not launch

BhamSoxFan
2010-02-13
2013-04-25
  • BhamSoxFan
    BhamSoxFan
    2010-02-13

    The download page says FG works with 10.6, but mine doesn't even launch.  The icon just bounces in the dock and then shows "Application not Responding".  This is from Console…

    2/12/10 11:50:45 PM FlightGear *** __NSAutoreleaseNoPool(): Object 0x60fea0 of class NSThread autoreleased with no pool in place - just leaking
    2/12/10 11:50:45 PM FlightGear RBCocoaInstallRubyThreadSchedulerHooks: couldn't find autoreleasePool ivar
    2/12/10 11:50:46 PM .net.sourceforge.macflightgear /Applications/FlightGear.app/Contents/Resources/FlightGearWindow.rb:21: ns_overrides is no longer necessary, should not be called anymore and will be removed in a next release. Please update your code to not use it.

    Thanks.

     
  • zloba_org
    zloba_org
    2010-10-30

    Same problem here - FG 2.0.0 fails to start on Mac OS X 10.6.

    FG 1.9.1 kinda works, but it has a list of issues, so I was hoping there have been some fixes:
    - some keys just don't work - e.g. keypad (there was simply no way to move the rudder left once it's moved right - had to tweak keyboard.xml - kinda worked, by remapping to letter keys).
    - that's because the Num Lock mode apparently has been completely removed from Mac OS X, at least 10.6 - couldn't find a way to enable Num Lock, after a lot of googling..
    - sound became flaky, then disappeared completely
    - Atlas map application, when it downloads data, pops up windows that steal focus from the main FG window and disrupt control, which can lead to a downward spiral if it happens at just the wrong moment.. which happened several times.
    - the whole thing crashed just when I was approaching the destination.. not the plane, but the program..

    But on the positive side, it exists, and I was able to get this thing to fly, which is awesome!

     
  • zloba_org
    zloba_org
    2010-10-30

    p.s. tried out the FlightGear-git-20100821.dmg snapshot - it appears to work better:
    - it runs, which is an important advantage
    - "move rudder left" with keypad 0 is fixed
    - there seem to be some interface improvements.

    Will be trying it out.

     
  • Lutz
    Lutz
    2010-11-01

    Hi,
    I use FlightGear with Mac OS X 10.6.3 and 10.6.4 a long time, without any problems.
    If I call fgfs -version, from the terminal, I get FlightGear and SimGear Version 2.0.0 and PLIB Version 185 and the fgfs Date is 12 Mar 2010. This is from the DMG File released in 18 Mar 2010.
    But I install the FlightGear Application in my User Application folder because FlightGear save some files into the Application Folder and I have no Write Access to the System Application Folder in general.
    Bye, Lutz