Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

usplash not working

Help
2009-05-25
2012-10-08
  • Hi,

    I tried many times without success (manually or with startupmanager) to install usplash on Ubuntu 9.04. I got the text instead when I boot.
    If I test with 'sudo usplash -c' i get the following message :

    usplash: can't get console font: Invalid argument
    usplash: No usable theme found for 1024x768
    screen init failed

    usplash seems to be installed correctly, /etc/alternatives/usplash-artwork.so link to /usr/lib/usplash/Mac4lin-usplash_1.0s.so

    I ran

    sudo update-alternatives --config usplash-artwork.so

    and choose on eo fthe 2 Mac4lin choices

    and

    sudo update-initramfs -u

    when I tried manually. I also tried to change resolution in /etc/usplash.conf to 800x600 and 640x480.

    The so files comes from subversion.

     
    • Peng Hardin
      Peng Hardin
      2009-05-25

      We need to recreate the upsplash for 9.04, and unfortunately I haven't had a chance to make it yet. I'll try to get it done in teh next couple of days.

       
    • Mj Mendoza IV
      Mj Mendoza IV
      2009-06-29

      any news on this? its still not working even if version 1.0 has been released.

       
      • Peng Hardin
        Peng Hardin
        2009-06-29

        I've been unable to get it working yet, due mostly due to a simple lack of available time on my Ubuntu box. The initial tests I made of usplashes on Ubuntu 9.04 failed, and I simply haven't had the time to try making them with a new method I found.

        I know this is definitely isn't good news, especially with M4L 1.0 coming out recently, but I hope to get things working before version 1.0.1 (or should that be 1.1?) comes out. We have several bugs to be squashed for the dot release and both infra and I are finding our available time for working on them squeezed short.

         
        • Pham Thanh Nam
          Pham Thanh Nam
          2009-06-30

          Please include also mac4lin usplash source, not only usplash.so binaries to support new Ubuntu releases.