#27 Build error - zlib : In file included from ./include/blk_dmg

open
Joseph Jezak
5
2010-05-21
2010-05-21
Anonymous
No

I'm using Gentoo and trying to build mol 0.9.72.1
Tried to emerge mol and it failed.
Tried to build it with from source with ./configure && make and it failed.
The messsage I got is exactly the same as this one I found at google.
http://www.mac-forums.com/forums/windows-classic-linux-other-os/197010-building-mac-linux.html
this is my gcc
gcc -v
Reading specs from /usr/lib/gcc/powerpc-unknown-linux-gnu/4.3.4/specs
Target: powerpc-unknown-linux-gnu
Configured with: /home/tmp/portage/sys-devel/gcc-4.3.4/work/gcc-4.3.4/configure --prefix=/usr --bindir=/usr/powerpc-unknown-linux-gnu/gcc-bin/4.3.4 --includedir=/usr/lib/gcc/powerpc-unknown-linux-gnu/4.3.4/include --datadir=/usr/share/gcc-data/powerpc-unknown-linux-gnu/4.3.4 --mandir=/usr/share/gcc-data/powerpc-unknown-linux-gnu/4.3.4/man --infodir=/usr/share/gcc-data/powerpc-unknown-linux-gnu/4.3.4/info --with-gxx-include-dir=/usr/lib/gcc/powerpc-unknown-linux-gnu/4.3.4/include/g++-v4 --host=powerpc-unknown-linux-gnu --build=powerpc-unknown-linux-gnu --enable-altivec --disable-fixed-point --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-multilib --enable-libmudflap --disable-libssp --enable-libgomp --disable-libgcj --enable-languages=c,c++,treelang --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu --with-bugurl=http://bugs.gentoo.org/ --with-pkgversion='Gentoo 4.3.4 p1.0, pie-10.1.5'
Thread model: posix
gcc version 4.3.4 (Gentoo 4.3.4 p1.0, pie-10.1.5)

and my zlib version
1.2.3-r1

best regards and thanks for the good work

feel free to contact me: tiago d0t caxias @t yahoo d0t com

Discussion

  • The build log

     
    Attachments