Hi,

Old issues are solved now, but substituted by new ones. Here's current situation.

By moving sources from "/home/admin/indexed-src/SW_200936/" to "/testFolder/SW_200936/" solved most of the problems. Currenly sources can be browsed via web interface and identifier search works ok. Remaining problem is general search. Even if I search text that is included in indexed files for sure, I get reply "0 files found." and error "Version 'SW_200936' has not been indexed and is unavailable for searching."
 
There seems to be one reported bug that is related to this same issue with "Version 'XXXXXXX' has not been indexed and is unavailable for searching.". I wonder is this fixed into lxr version lxr-0.9.6 or fixed at all. https://bugs.maemo.org/show_bug.cgi?id=406

Br,
Heikki
 

On Tue, Nov 3, 2009 at 9:50 AM, Tommi Halonen <tommi@droit.fi> wrote:
Back in the business after a while...
DrRoessi continued our effort to get LXR running and got already some new
info. Could you please post the current situation here.

Big thanks Malcolm for your support!

-Tommi


On Wed, 21 Oct 2009 10:21:23 +0100, Malcolm Box <malcolm.box@gmail.com>
wrote:
> On Tue, Oct 20, 2009 at 3:40 PM, Tommi Halonen <tommi@droit.fi> wrote:
>> On Mon, 19 Oct 2009 19:08:25 +0100, Malcolm Box <malcolm.box@gmail.com>
>> wrote:
>>>
>>> Looking at the config file, your source code should be in the
directory:
>>>
>>> /home/admin/indexed-src/SW_200936/
>>>
>>> does this directory exist?
>>
>> Yes it does. It and its sub directories also all have read and execute
>> rights for u/g/o (which might not be a good idea, but I wanted to make
>> sure
>> it's not causing problems). Is Apache looking for the source files
>> directly
>> from there or from the DB?
>
> LXR loads the source files directly from there, they are not saved in
> the database.
>
> This is puzzling - as far as I can see the configuration is correct
> and you should be seeing the source files.
>
> Can you confirm that genxref has successfully put data in the database
> - ie you saw a log of each file processed when you ran genxref, and
> the database has contents?  If that's the case then LXR can definitely
> find the code.
>
> When you say the portal displays fine at http://myip/lxr/source/, do
> you mean you see the LXR header etc but where you would expect to see
> a listing of the top level directory of the source code you see "The
> directory / does not exist"?
>
> If none of those provide a eureka moment then could you try adding
> some debug prints to LXR to see what's going wrong?
>
> - At around line 150 of source, where it reads:
>   151 @nodes = $files->getdir($dir, $releaseid);
>   152         unless (@nodes) {
>   153                 print(  "<p align=\"center\">\n<i>The directory " . $dir
>   154                           . " does not exist.</i>\n");
>
> Can you add a print of $releaseid and $files
>
> Then in lib/LXR/Files/Plain.pm at line 99
>   99    sub getdir {
>   100         my ($self, $pathname, $releaseid) = @_;
>   101         my ($dir, $node, @dirs, @files);
>
> Add a print of $pathname, $releaseid, and at line 108
> 107   $dir = $self->toreal($pathname, $releaseid);
>   108         opendir(DIR, $dir) || return ();
>
> add a print of $dir which will show what directory LXR is trying to open.
>
> Hopefully one of these will reveal what's going wrong!
>
> Cheers,
>
> Malcolm
>
>
------------------------------------------------------------------------------
> Come build with us! The BlackBerry(R) Developer Conference in SF, CA
> is the only developer event you need to attend this year. Jumpstart your
> developing skills, take BlackBerry mobile applications to market and stay

> ahead of the curve. Join us from November 9 - 12, 2009. Register now!
> http://p.sf.net/sfu/devconference
> _______________________________________________
> Lxr-general mailing list
> Lxr-general@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/lxr-general