error message in SimpleParse.pm

2001-10-27
2001-12-27
  • Hi!

    After installing DBI I run genxref script and after quite some messages about indexation being done, I get the following error:

    --- /plugins/picts/picts_plugin.c 4
    Can't call method "getline" on an undefined value at lib/LXR/SimpleParse.pm line 97.

    If I run genxref again, it proceeds and gets stuck in the next file, and so on.

    Any hints?

    Also, is there a proper procedure to clean the indexation data and restart in a clean way?

    Thanks,

    Fernando

     
    • Shree
      Shree
      2001-12-27

      I guess the reply is very  late. Maybe you have it working already...

      About the "SimpleParse" problem:

      I was trying to get LXR 0.9 working on Windows 2000/Apache and after some looking around, I was able to solve the problem.

      To generate references to identifiers, LXR creates some temporary files in the /tmp directory. In all probability, you are trying to get LXR working on Windows. So it is likely that you don't have a /tmp directory in whichever drive you ran genxref from. Create it & it will work.

      About cleanup:

      It might be possible to write a query [if you are using MySQL as the backend] to do the cleanup - but since I am currently experimenting, I find it easier to just run initdb-mysql again !

      Hope this helps.

      - Shree Kumar