Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Installation did not work

Problems
2012-04-09
2013-05-28
  • I am using xbmcbuntu eaden ( ubuntu 11.10 with xbmc media center added )
    I would appreciate any help in getting it to work.

    these are the steps I did

    /lxmed$ sudo ./install.sh
    Installing application…

    Removing any previous installed files and folders…
    removed `/opt/lxmed/uninstall.sh'
    removed `/opt/lxmed/LXMenuEditor.jar'
    removed `/opt/lxmed/lxmed.png'
    removed directory: `/opt/lxmed'
    removed `/usr/share/applications/lxmed.desktop'
    rm: cannot remove `/bin/lxmed': No such file or directory
    removed `/usr/bin/lxmed'
    mkdir: created directory `/opt/lxmed'
    `content/lxmed' -> `/usr/bin/lxmed'
    mode of `/usr/bin/lxmed' changed to 0755 (rwxr-xr-x)
    `content/LXMenuEditor.jar' -> `/opt/lxmed/LXMenuEditor.jar'
    `content/uninstall.sh' -> `/opt/lxmed/uninstall.sh'
    mode of `/opt/lxmed/uninstall.sh' retained as 0755 (rwxr-xr-x)
    `content/lxmed.png' -> `/opt/lxmed/lxmed.png'
    `content/lxmed.desktop' -> `/usr/share/applications/lxmed.desktop'

    Installation sucessfully completed. Enter lxmed to run application or check Preferences -> Main Menu Editor in your main menu

    first problem was
    /Downloads/lxmed$ gksu lxmed
    Gtk-Message: Failed to load module "canberra-gtk-module"
    (gksu:7566): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    fixed by installing the following via synaptic
    Installed the following packages:
    libcanberra-gtk-module (0.28-0ubuntu11)
    libcanberra-gtk0 (0.28-0ubuntu11)

    but still get
    (gksu:7566): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    any ideas

    Thaks
    Dave

     
  • Is it posible I do not have the correct java installed?

    Dave

     
  • I just noticed that I get the same error when I start leafpad, except it works.

    sudo leafpad /etc/xdg/lxsession/XBMCbuntu/autostart

    (leafpad:2192): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

    thanks
    dave

     
  • I'm not sure what's the problem. It's a pure Java application and uses Java Metal GUI Theme, so it doesn't depend on system themes. Maybe it's something with that version of Ubuntu (I mean xbmc). I'm not sure this app can work correctly with this version. lxmed is targeted to LXDE and similar lightweight environments.

    If you're using OpenJDK, try installing Oracle JRE. You can install either JRE6 or JRE7.

     
  • Thanks for your help
    some openjdk packages missing

    just in case it is of help to anyone

    Installed the following packages:
    default-jre (1:1.6-42ubuntu2)
    icedtea-netx (1.1.3-1ubuntu1.1)
    libaccess-bridge-java (1.26.2-6)
    libaccess-bridge-java-jni (1.26.2-6)
    openjdk-6-jre (6b23~pre11-0ubuntu1.11.10.2)

    Thanks for your help
    Dave