Lxmed won't start [Fedora 16]

Problems
2012-01-13
2013-05-28
  • Hello. When I'm launching lxmed from start menu, nothing happens, but if I try the same through console, I get the following errors:

    /usr/bin/lxmed: line 16: Debian=RedHat: command not found
    /usr/bin/lxmed: line 32: gksu: command not found
    

    How can I solve them?

     
  • Marko Čičak
    Marko Čičak
    2012-01-13

    It looks like you don't have gksu command installed. It is used for gaining root privileges when running lxmed. Do you perhaps know if Fedora has other command used for running applications as sudo (root)? If so, you can manually change the /usr/bin/lxmed script, line 32 which starts with
    gksu - message …

    You can also try to make line 32 look like this:
    java -jar /opt/lxmed/LXMenuEditor.jar
    but then lxmed won't run with root privileges.

     
  • Jose:

    In last releases of Fedora, the "gksu" command changed to "beesu". So, you can start lxmed by

    $beesu lxmed
    

    . All the apps that you need start with root privileges in graphic mode in Fedora (14, 15, 16…) you must to use beesu command.
    After, go to "Preferences" category in lxmed and change "Main menu editor" entry (this is the entry of lxmed in the applications menu of your system), in command write:  beesu java -jar /opt/lxmed/LXMenuEditor.jar. Don't wrtite only "beesu lxmed", because the lxmed start script fails in Fedora (something about checkup of Fedora release).

     
  • I ran the first time like this

    sudo java -jar /opt/lxmed/LXMenuEditor.jar
    

    For some reason the app itself doesn't appear in the options so I added a new one with the command option like this

    beesu java -jar /opt/lxmed/LXMenuEditor.jar
    
     
  • There I found it,was under preferences category, and just read the guy above already gave the solution

     
  • The problem on line 16 is a dollar sign infront of the variable DISTRO that cause BASH to use the variable's value "Debian".

    The problem in line 32 is that Fedora doesn't come with gksu.  beesu seems to be the prefered graphical su for Fedora.

    To get beesu:

    # yum install beesu
    

    Then replace /usr/bin/lxmed with this version:

     1
     2
     3
     4
     5
     6
     7
     8
     9
    10
    11
    12
    13
    14
    15
    16
    17
    18
    19
    20
    21
    22
    23
    24
    25
    26
    27
    28
    29
    30
    31
    #!/bin/bash
    # discovered distro; Debian by default
    DISTRO='Debian'
    # distro names
    DEBIAN='Debian'
    SUSE='SuSe'
    REDHAT='RedHat'
    MANDRAKE='Mandrake'
    #######################################################################
    # DISTRIBUTION DETECTION
    ########################################################################
    if [ -f /etc/redhat-release ] ; then
        DISTRO=$REDHAT
    elif [ -f /etc/SuSE-release ] ; then
        DISTRO=$SUSE
    elif [ -f /etc/mandrake-release ] ; then
        DISTRO=$MANDRAKE
    elif [ -f /etc/debian_version ] ; then
        DISTRO=$DEBIAN
    fi
    ########################################################################
    # start the application
    if [ "${DISTRO}" = "${SUSE}" ];
    then
        gnomesu --command "java -jar /opt/lxmed/LXMenuEditor.jar"
    elif [ "${DISTRO}" = "${REDHAT}" ];
    then
        beesu -c "java -jar /opt/lxmed/LXMenuEditor.jar"
    else
        gksu --message "Please enter password to run lxmed in fully operational mode:" 'java -jar /opt/lxmed/LXMenuEditor.jar'
    fi
    

    I think that should take care of your problem.

    -Michael

     
  • Marko Čičak
    Marko Čičak
    2012-05-23

    I just installed Fedora 16 LXDE and it doesn't have 'gksu' nor 'beesu' command installed by default installation :(

    Is there something else that comes in fedora by default?

    Also, I added a help info for those running fedora:
    http://lxmed.sourceforge.net/help.html#java