2009/12/11 Andrea Florio <andrea@opensuse.org>
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Il 11/12/2009 20:33, Christoph Wickert ha scritto:
> I am very concerned about the recent LXDE updates:
>
>       * After updating to lxsession-0.4.1, lxde-common-0.5.0 and
>         lxappearance 0.3.0, I can no longer log into LXDE. Instead I get
>         back to the login screen after a second. It doesn't work with a
>         new user ether, so it's not related to my configuration. Any
>         ideas how to debug this?

i fixed it changing startlxde script


 # Start the LXDE session
- -exec @prefix@/bin/lxsession -s LXDE
+exec @prefix@/bin/lxsession -s LXDE -e LXDE


The lxde-common-0.5.0 dist tarball does not match the source from SVN commited as 0.5.0 release:

[juergen@bitzer lxde-common]$ git log --grep=0.5.0  --oneline 
aa8b0fd Release lxde-common 0.5.0. Remove icon theme from it.
[juergen@bitzer lxde-common]$ git checkout aa8b0fd 
...
HEAD is now at aa8b0fd... Release lxde-common 0.5.0. Remove icon theme from it.
[juergen@bitzer lxde-common]$ tar xf ${ARCH_DISTDIR}/lxde-common-0.5.0.tar.gz -O   lxde-common-0.5.0/startlxde.in|diff -u - startlxde.in 
--- - 2010-01-18 23:02:45.344199353 +0100
+++ startlxde.in 2010-01-18 23:01:56.000000000 +0100
@@ -25,4 +25,4 @@
 export SAL_USE_VCLPLUGIN=gtk
 
 # Start the LXDE session
-exec @prefix@/bin/lxsession -s LXDE
+exec @prefix@/bin/lxsession -s LXDE -e LXDE


@PCMan : The build of the dist tarball went wrong?

We should prepare a new dist tarball.

Jürgen