#576 Application launcher icon not showing transparent background

None
closed-fixed
lxpanel (238)
5
2014-09-04
2013-03-18
Glenn
No

Originally, I reported this bug to Debian Bug Tracking System <650821@bugs.debian.org> Dec. 3, 2011. I submitted a followup today.

Summary: Application launcher icons are not showing transparent background on initialization of the panel.

Here is a copy of the followup message.

Package: lxpanel
Version: 0.5.10-1
Followup-For: Bug #650821 (Debian Bug Tracking System <650821@bugs.debian.org>)

This bug still exists in v0.5.10. I am fairly certain this is an
initialization bug when the panel is in auto-hide mode. Right-clicking on the
panel after initialization, choosing Panel Settings, and changing a value that
causes the panel to be repainted fixes the issue for the rset of the session.
My usual practice is to increase the value for Margin from 0 to 1 and back to 0
on the Panel Preferences dialog and close the dialog. After doing so,
application icons show a transparent backgruond for the rest of the session.
These are the icons next to the Menu button/icon, not the ones that show which
applications are currently open in the current workspace.

-- System Information:
Debian Release: 7.0
APT prefers testing
APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-4-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages lxpanel depends on:
ii libasound2 1.0.25-4
ii libatk1.0-0 2.4.0-2
ii libc6 2.13-38
ii libcairo2 1.12.2-3
ii libfontconfig1 2.9.0-7.1
ii libfreetype6 2.4.9-1.1
ii libgdk-pixbuf2.0-0 2.26.1-1
ii libglib2.0-0 2.33.12+really2.32.4-5
ii libgtk2.0-0 2.24.10-2
ii libiw30 30~pre9-8
ii libmenu-cache1 0.3.3-1
ii libpango1.0-0 1.30.0-1
ii libwnck22 2.30.7-1
ii libx11-6 2:1.5.0-1
ii lxmenu-data 0.1.2-2

lxpanel recommends no packages.

Versions of packages lxpanel suggests:
ii epiphany-browser [www-browser] 3.4.2-2.1
ii google-chrome-stable [www-browser] 20.0.1132.57-r145807
ii iceweasel [www-browser] 10.0.12esr-1
ii links [www-browser] 2.7-1
ii lxsession 0.4.6.1-4
ii menu 2.1.46
ii w3m [www-browser] 0.5.3-8

Discussion

  • I believe this issue is completely fixed in latest version of LXPanel - 0.7.0. Try it, please, and let us know if something is still wrong. Thank you very much.

     
    • status: open --> closed-fixed
    • assigned_to: Lonely Stranger
    • Group: --> -