#243 crash in lxpanel-0.5.5-3.fc13: __strftime_internal

None
closed
martyj19
lxpanel (233)
7
2014-11-18
2010-07-16
No

Forwarded from https://bugzilla.redhat.com/show_bug.cgi?id=600763

abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: lxpanel --profile LXDE
comment: Absturz ohne erkenntlichen Grund, es könnte sein, dass ich gerade
versucht hab die Uhr anzuklicken.
component: lxpanel
crash_function: __strftime_internal
executable: /usr/bin/lxpanel
global_uuid: 22087087a44adfd7db27e36d64c7b7acab230538
kernel: 2.6.33.3-85.fc13.x86_64
package: lxpanel-0.5.5-3.fc13
rating: 4
reason: Process /usr/bin/lxpanel was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

Discussion

  • backtrace of the crash

     
    Attachments
  • Sorry, I should have translated the comment. It means: "Crash without obvious reason, could be that I tried to click the clock."

     
  • https://bugzilla.redhat.com/show_bug.cgi?id=607473 has a secondy bug report that seems to be related:

    abrt 1.1.1 detected a crash.

    architecture: x86_64
    Attached file: backtrace
    cmdline: lxpanel --profile LXDE
    comment: reading the variables in the field in real-time causes the program to
    crash. That's the behaviour of most applications, but reading a null causes it
    to crash. It should check for the field to show nothing but not crash when the
    field is empty.
    component: lxpanel
    crash_function: __strftime_internal
    executable: /usr/bin/lxpanel
    global_uuid: 404fca3641d551bdaba48ad720764539754bdd35
    kernel: 2.6.33.5-124.fc13.x86_64
    package: lxpanel-0.5.5-3.fc13
    rating: 4
    reason: Process /usr/bin/lxpanel was killed by signal 11 (SIGSEGV)
    release: Fedora release 13 (Goddard)

    How to reproduce
    -----
    1. digital clock settings
    2. clear "clock format" field
    3. bang. crash.

     
  • backtrace of the related bug

     
    Attachments
  • martyj19
    martyj19
    2010-07-17

    • status: open --> closed-fixed
     
  • martyj19
    martyj19
    2010-07-17

    Fixed in git commit c96c6d684b60bd697583987c03c1c0cd318f70f4.

     
    • status: closed-fixed --> open
     
  • The fix does not work. Even 0.5.6 with the patch crashes.

     
  • backtrace of the lxpanel-0.5.6

     
    Attachments
  • I believe this issue is fixed in the current lxpanel, because corresponding code was changed carefully some time ago. Reopen it, please, if such problem still exists. Thank you very much.

     
    • status: open --> closed
    • Group: -->