#14 could not read directory content!

closed
Florin Malita
None
5
2002-09-30
2002-09-16
Sergey M. Serov
No

[ky@kyl ky]$ uname -a
Linux kyl 2.4.19-7mdk #1 Fri Aug 30 07:19:03 CEST 2002 i686
unknown unknown GNU/Linux

starting the deamon:
[root@kyl root]# su - lufs -c 'lufsd'
[b1a](Config)
[b1a](load)class: FTPFS, prop: DataConnectionMode, value:
Active
[b1a](load)no such class, creating...
[b1a](load)class: FTPFS, prop: RWTimeout, value: 10
[b1a](run)daemon started...

tryng to mount and ls:
root@kyl root]# lufsmount localfs:// /mnt/test
ls /mnt/test

output from deamon:

Sep 16 20:55:08 kyl kernel: (lu_read_super) - in
Sep 16 20:55:08 kyl kernel: (lu_mount) - mount OK
Sep 16 20:55:08 kyl kernel: (lu_iget) - in
Sep 16 20:55:08 kyl kernel: (set_inode_attr) - in
Sep 16 20:55:08 kyl kernel: (set_inode_attr) - out
Sep 16 20:55:08 kyl kernel: (lu_iget) - it's a dir.
Sep 16 20:55:08 kyl kernel: (lu_read_super) - mount succeded:
/tmp/lufsdy0RJus

Sep 16 20:55:56 kyl kernel: (lu_readdir) - in
Sep 16 20:55:56 kyl kernel: (lu_getmount_point) - vfs
mountpoint: /mnt/test
Sep 16 20:55:56 kyl kernel: (lu_readdir) - mount_point: /mnt/test
Sep 16 20:55:56 kyl kernel: (lu_getname) - root: , rootlen: 0,
namelen: 0
Sep 16 20:55:56 kyl kernel: (lu_getname) - name resolved to /
Sep 16 20:55:56 kyl kernel: (lu_readdir) - reading /...
Sep 16 20:55:56 kyl kernel: (lu_execute) - slot not connected.
Sep 16 20:55:56 kyl kernel: (slot_reconnect) - successfully
reconnected.
Sep 16 20:55:56 kyl kernel: (do_execute) - sock_recv failed!
Sep 16 20:55:56 kyl kernel: (lu_execute) - do_execute failed!
Sep 16 20:55:56 kyl kernel: (slot_reconnect) - closing socket.
Sep 16 20:55:56 kyl kernel: (slot_reconnect) - successfully
reconnected.
Sep 16 20:55:56 kyl kernel: (do_execute) - sock_recv failed!
Sep 16 20:55:56 kyl kernel: (lu_execute) - error executing
command!
Sep 16 20:55:56 kyl kernel: (lu_readdir) - could not read directory
content!

Discussion

    • assigned_to: nobody --> mali
     
    • status: open --> closed
     
  • Logged In: YES
    user_id=612196

    seems to be fixed in the last version
    all works just fine