#1 Firefox plugin, FF3.5+

open
nobody
None
5
2010-03-09
2010-03-09
Anonymous
No

The plugin released is no longer compatible with firefox 3.5+

Discussion