#27 Patch required for lpq.c to build under gcc 4.1.1

closed
nobody
None
5
2006-12-03
2006-06-03
Rudi Heitbaum
No

Error during build. Gcc 4.1.1 is pedantic:

*** LPRng-3.8.28/src/common/lpq.c-orig Sat Jun 3
22:23:31 2006
--- LPRng-3.8.28/src/common/lpq.c Sat Jun 3
22:22:11 2006
***************
*** 449,455 ****
if( (pid = dofork(0)) == 0 ){
setuid( OriginalRUID );
close_on_exec(3);
! execl(CLEAR,0);
exit(1);
} else if( pid < 0 ){
LOGERR_DIE(LOG_ERR) _("fork()
failed") );
--- 449,455 ----
if( (pid = dofork(0)) == 0 ){
setuid( OriginalRUID );
close_on_exec(3);
! execl(CLEAR,0,(char *)NULL);
exit(1);
} else if( pid < 0 ){
LOGERR_DIE(LOG_ERR) _("fork()
failed") );

Discussion

  • grumpf_
    grumpf_
    2006-12-03

    • status: open --> closed
     
  • grumpf_
    grumpf_
    2006-12-03

    Logged In: YES
    user_id=1456210
    Originator: NO

    actualy we decided on execl(CLEAR,CLEAR,NULL);
    problem fixed