Thanks Tim. Must beca local issue (sigh)  cheers
g


Sent from my smartphone. 


"Tim E. Real" <termtech@rogers.com> wrote:
On March 16, 2013 11:10:54 PM Geoff Beasley wrote:
> Tim
> I'm having trouble with vst plugs now - ones that did work dont now.
> have there been any changes lately that could effect them?
>
> running "Rough Rider" gives me in the console:
> <snip>
> RemoteVSTClient: executing /usr/lib/dssi/dssi-vst/dssi-vst-server
> RoughRider.dll,2Sw5TIIyEdy5F4Wlcs0diuQO
> DSSI VST plugin server v0.986
> Copyright (c) 2004-2010 Chris Cannam
> Loading "RoughRider.dll"...
> dssi-vst-server[1]: found in /root/vst/RoughRider.dll
> done
> Testing VST compatibility...
> dssi-vst-server[1]: VST entrypoint "VSTPluginMain" found
> fixme:win:EnumDisplayDevicesW ((null),0,0x32f4d8,0x00000000), stub!
> dssi-vst-server[1]: plugin instantiated
> dssi-vst-server[1]: plugin is a VST
> dssi-vst-server[1]: plugin has a GUI
> dssi-vst-server[1]: plugin supports processReplacing
> dssi-vst-server[1]: opening plugin
> dssi-vst-server[1]: plugin is VST 2.0 or newer
> dssi-vst-server[1]: plugin is not a synth
> dssi-vst-server[1]: plugin can receive MIDI anyway
> dssi-vst-server[1]: plugin name is "Rough Rider"
> dssi-vst-server[1]: vendor string is "Audio Damage, Inc."
> Initialising Windows subsystem...
> dssi-vst-server[1]: registered Windows application class "dssi_vst"
> dssi-vst-server[1]: created main window
> done
> dssi-vst-server[1]: created audio thread
> cannot create dummy timer window
> DSSIVSTPluginInstance(0xadeb198): setting OK true
> DSSIVSTPluginInstance::DSSIVSTPluginInstance(RoughRider.dll)
> construction complete
> dssi-vst-server[1]: set sample rate to 48000
> client sized shm to 1024
> dssi-vst-server[1]: set buffer size to 64
> RemoteVSTServer::setParameter (0,0.5): 0 events expected
> RemoteVSTServer::setParameter (1,0.5): 0 events expected
> RemoteVSTServer::setParameter (2,0.25): 0 events expected
> RemoteVSTServer::setParameter (3,0.5): 0 events expected
> RemoteVSTServer::setParameter (4,0.5): 0 events expected
> RemoteVSTServer::setParameter (5,1): 0 events expected
> sized shm to 1024, 2 inputs and 2 outputs
>
> seems itm should work but when it's in line i get silence
>
> best
>
> g
>
>

Downloaded RoughRider 32 bit Win VST and tested OK here
in a plugin rack, no trouble.

I get sound and all controls work.

???

One oddity: The Native GUI has an 'Active' switch that turns
it on or off. But the generic GUI's 'Active' slider has a continuous
action - not on or off - gradually altering the sound.

Tim.

------------------------------------------------------------------------------
Everyone hates slow websites. So do we.
Make your web apps faster with AppDynamics
Download AppDynamics Lite for free today:
http://p.sf.net/sfu/appdyn_d2d_mar
_______________________________________________
Lmuse-developer mailing list
Lmuse-developer@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/lmuse-developer