looks like we have to either publish muse under the GPL3 or use an older feta font (from 2009).
using an older font is not a problem as long as the glyphs don't look ugly (feta had major improvements in being rendered to small glyphs (which is what we need), but i dunno if that was before or after 2009)

i've asked on lilypond's developer mailing list, the answer follows:

-------- Original Message --------
Betreff: Re: using the feta font in a GPL2 application
Datum: Mon, 28 Mar 2011 15:08:32 +0100
Von: Graham Percival <graham@percival-music.ca>
An: Florian Jung <florian.a.jung@web.de>
CC: lilypond-devel@gnu.org <lilypond-devel@gnu.org>


On 3/28/11, Florian Jung <florian.a.jung@web.de> wrote:
> Am 28.03.2011 15:33, schrieb Carl Sorensen:
>> As far as permission to use it the current font under GPL2, I think
>> Han-Wen and Jan need to give that permission.
>
> i assume Han-Wen and Jan also read that mailing list, so i'm asking for
> permission to use the current font :)

I believe that *everybody* who has worked on the feta fonts would need
to give that permission.  You can find this list by looking at the git
changelog messages for those files, but I do not recommend going
further with this.  I really recommend that you either use the old
GPLv2 feta fonts, or use GPLv3 (possibly 3+) for your application.

It's unfortunate that copyright law gets in the way like this, but it does.

Cheers,
- Graham