#128 Builtin Synths stuck with the last played Tone

cvs(HEAD)
closed-fixed
nobody
Audio (19)
5
2006-03-26
2006-03-19
Hartmut Noack
No

If i setup a miditrack in Muse 0.8, that plays one of
the builtin synths (vam, deiconze or organ), the synth
stuck with the last played tone when stopping
transport. This does not happen with simpledrums or
external synths like ZynaddSubFX. It does not happen
also, if i just "play" the synth with the pianoroll of
the Matrixeditor.
Hitting the "panic"-button does not help.

xterm prints stuff like this:

zettberlin@zettsusenova:~> muse
Trying RTC timer...
fatal error: open /dev/rtc failed: Keine Berechtigung
Trying ALSA timer...
got timer = 11
starting with default template
AlsaTimer::setTimerTicks(): requested freq 1024 Hz too
high for timer (max i
s 1000)
freq stays at 1000 Hz
set realtime scheduler: Die Operation ist nicht erlaubt
midi thread 8683 _NOT_ running SCHED_FIFO
AlsaTimer::stopTimer(): timer stop -14 (Ungültige Adresse)
AlsaTimer::setTimerTicks(): requested freq 1024 Hz too
high for timer (max i
s 1000)
freq stays at 1000 Hz
set realtime scheduler: Die Operation ist nicht erlaubt
midi thread 8683 _NOT_ running SCHED_FIFO
SimpleSynth sampleRate 44100
AlsaTimer::setTimerTicks(): requested freq 1024 Hz too
high for timer (max i
s 1000)
freq stays at 1000 Hz
set realtime scheduler: Die Operation ist nicht erlaubt
midi thread 8683 _NOT_ running SCHED_FIFO
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
MessSynthIF::getData - time is 0!
Speicherzugriffsfehler

Discussion

  • Robert Jonsson
    Robert Jonsson
    2006-03-19

    Logged In: YES
    user_id=81832

    I'm not sure this is the problem but the message "set
    realtime scheduler: Die Operation ist nicht erlaubt"
    indicates that MusE wants to set the priority of several
    threads to realtime but fails.
    And stopTimer is called, wierd stuff, I'll investigate.

    Is jack successfully running with -R ?

    My german is a bit dusty and you didn't mention any
    crashes, but isn't "Speicherzugriffsfehler" segmentation
    fault?

     
  • Hartmut Noack
    Hartmut Noack
    2006-03-20

    Logged In: YES
    user_id=843133

    Your German is sure better than my swedish ;-)
    Yes: i run all the stuff on Suse *whithout* -R since i can
    use the hardwaremonitoring of the envy24-Chipset and because
    it works very good with Ardour, mhwaveplayer, Zynadd etc etc
    and with Muse 7.2 also.

    On the Toshiba i run jackstart -R with the
    realtimecapabilities of the UBUNTU dapper drake Kernel - no
    Problems here with Ardour, H" etc also.

    You are right again: "Speicherzugriffsfehler" is
    "segmentation fault" : this is only the result of
    terminating Muse by using the x-button at the windowdeco - i
    am not aware, if this happens also if i exit Muse via the
    File-Menu but i think, this is not an issue - Muse did not
    crash but was terminated wilingly ;-)

     
  • Hartmut Noack
    Hartmut Noack
    2006-03-20

    Logged In: YES
    user_id=843133

    Shame on me, again i have forgotten to post my Systemsetup:

    1.) PVI-Standard-PC with Terratec EWX24/96 (envy24), Suse
    9.3, gcc (GCC) 3.3.5, QT is 3.3.4-11.3, alsa 1.0.9-9.1, jack
    0.100

    2.) Toshiba Tecra PIII 1200MHz Laptop
    UBUNTU dapper drake preflight 4 alsa 1.0.10-4, gcc
    3.3.6-10,QT 3.3.5-1, jack0.100

     
  • Robert Jonsson
    Robert Jonsson
    2006-03-21

    Logged In: YES
    user_id=81832

    This is getting somewhat from the subject but something
    seems wrong with your setup. For starters that
    MusE crashes on exit is not normal. The realtime errors
    above look somewhat serious too.

    I see that you run jackstart, I think jackstart is only to
    be used for 2.4 kernels. Dapper has 2.6 right?
    Try starting jack with:
    jackd -R -d hw:0
    or if not -R
    jackd -d hw:0

    As for the actual error I have confirmed it. The panic
    button does however work for organ but not for vam and
    deicsonze.

     
  • Hartmut Noack
    Hartmut Noack
    2006-03-21

    Logged In: YES
    user_id=843133

    Thanks for the hint - it worked OK with jackstart(i used it,
    because it was the default in qjackctl) but it was not
    perfectla stable - jackd -R works very good..

    Do i need to set up the kernel to get the RTC to work with
    muse? (running muse sudo does not help...).

    >The panic button does however work for organ
    confirmed: the same here, vam, s1 and deicsonze do not
    respond/stop

     
  • Hartmut Noack
    Hartmut Noack
    2006-03-22

    Logged In: YES
    user_id=843133

    Did some more tests on my UBUNTU-dapper-Laptop, Midi | Reset
    instruments serves as a Panicbutton for deicsonze, vam and
    s1, the wavefile-effect is the same as on Suse 9.3.
    Consider 2 complete different setups, soundchips, distros,
    kernelsetups and jackd-settings - even slightly different
    ./configure - flags (both without ladcca, with gnu-ld on
    Suse and withoud fluidsynth on UBUNTU...)

     
  • Robert Jonsson
    Robert Jonsson
    2006-03-25

    Logged In: YES
    user_id=81832

    Thank you for this information, atleast there is a
    workaround then.

     
  • Robert Jonsson
    Robert Jonsson
    2006-03-26

    • status: open --> closed
     
  • Robert Jonsson
    Robert Jonsson
    2006-03-26

    Logged In: YES
    user_id=81832

    Fixed in cvs for REL07

     
  • Robert Jonsson
    Robert Jonsson
    2006-03-26

    • status: closed --> closed-fixed