Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#101 Help menu segfaults

0.7.x
closed-fixed
nobody
None
5
2005-05-11
2005-05-10
Philip Nelson
No

in .7.2pre1 I get seg faults when using the Manual,
MusE web site or Report a bug link. There are no lines
output when starting with -D so I am not really sure
how to troubleshoot this.

Discussion

  • Robert Jonsson
    Robert Jonsson
    2005-05-10

    Logged In: YES
    user_id=81832

    Ok, these alternatives all have to do with web browsers.

    I recall vaguely some similar report a long time ago. Do you know
    what webbrowsers are installed on your system?
    Also check what browser MusE detected, available in Settings->Global
    settings->GUI.
    What user is MusE started as?

     
  • Philip Nelson
    Philip Nelson
    2005-05-10

    Logged In: YES
    user_id=532744

    OK the "help browser" field was blank. Is global settings
    per user? If so, then it's possible it was blank because of
    the earlier install(s) which go back to .63.

    Putting in /usr/bin/firefox makes everybody happy, so the
    menu should probably be grayed out with hover text stating
    that a browser needs to be selected? That's simple enough,
    perhaps I can make a patch.

    Muse is running suid root.

     
  • Philip Nelson
    Philip Nelson
    2005-05-11

    Logged In: YES
    user_id=532744

    This attached patch should do it. I wonder what the overall
    strategy is for sanity checking the configuration file. It
    seems like the current version could fail in many places,
    but this patch only addresses the helpbrowser segfault.

     
  • Philip Nelson
    Philip Nelson
    2005-05-11

     
    Attachments
  • Robert Jonsson
    Robert Jonsson
    2005-05-11

    Logged In: YES
    user_id=81832

    Thanks, I'll take a look at it.

    Though I still don't understand why it crashes. There is a test that
    checks if the string is empty. Perhaps different qt versions behave
    differently.

    As for config validation, feel free to take the discussion to the devel
    mailinglist.

     
  • Robert Jonsson
    Robert Jonsson
    2005-05-11

    Logged In: YES
    user_id=81832

    > Though I still don't understand why it crashes. There is a test that
    > checks if the string is empty. Perhaps different qt versions
    > behave
    > differently.

    Ok, got it, if the tag exists but is empty it fails.

     
  • Robert Jonsson
    Robert Jonsson
    2005-05-11

    • status: open --> closed-fixed