Yea, I have no idea about WinXP, unless you only have the libsndfile libs without the devel stuff? I can try to compile it on my copy of Windows 7, and let you know how it turns out. I'll try to get back with my results eventually.

On Mon, Oct 24, 2011 at 11:16 AM, <quadro2@email.cz> wrote:
Hello,

Thanks for the test, I have issue on WinXP 32bit to get it compiled,
to se wether it works on windows as well. As that sndfile - cmake
module not found error below, I think there is some additional
configuration to cmake needed. Any ideas?

Here is the error once again: (I have added libsnd1 to PATH variable
and some other places, maybe I am missing some cmake configuration
file).

CMake Error at C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/
FindPkgConfig.cmake:266 (message):
                                   A required package was not found

                               Call Stack (most recent call first):

  C:/Program Files/CMake 2.8/share/cmake-2.8/Modules/FindPkgConfig.
                            cmake:320 (_pkg_check_modules_internal)

                             CMakeLists.txt:106 (PKG_CHECK_MODULES)

                       CMake Error at CMakeLists.txt:108 (MESSAGE):

   LMMS requires libsndfile1 and libsndfile1-dev >= 1.0.11 - please
                                                           install,

                               remove CMakeCache.txt and try again!

Best regards,

------------ Původní zpráva ------------
Od: John Serafino <lzrblade@gmail.com>
Předmět: Re: [LMMS-devel] [Lmms-users] LMMS patch for loading VST
presets (fxp, fxb)
Datum: 22.10.2011 23:43:25
---------------------------------------------




From: John Serafino <lzrblade@gmail.com(mailto:lzrblade@gmail.com)>
Date: Sat, Oct 22, 2011 at 1:19 PM
Subject: Re: Re: [LMMS-devel] [Lmms-users] LMMS patch for loading
VST presets (fxp, fxb)
To: quadro2@email.cz(mailto:quadro2@email.cz)


Compiles and runs like a dream for me on Ubuntu 11.10.






On Sat, Oct 22, 2011 at 4:39 AM, <quadro2@email.cz
(mailto:quadro2@email.cz)> wrote:
Hello,



I have made a separated patch for this loader (see attachment),
thought I'm not able to compile and test it for Windows still.




After installing libsndfile1 and pkg-config, adding them to the PATH
env.,

this error is displayed in qt-creator still:











--
John






--
John




--
John