Fedora really doesn't have any packages with 'multilib' in its name. Just give it all that it needs,
i.e. install glibc-devel.i386 (note the '.i386' :)