Thanks for a prompt reply. One thing - could you provide me with the full svn path I should checkout? I could not find lmms-extras anywhere in the tree.

-Piotr

On Tue, Oct 14, 2008 at 11:01 AM, Tobias Doerffel <tobias.doerffel@gmail.com> wrote:
Hi,

On Tuesday 14 October 2008 09:42:58 Piotr Siwczak wrote:
> Can anyone tell me if the support for zynaddsubfx is available in current
> 0.4.0-rc2? On the kvr forum I found that one can browse and add zynaddsubfx
> sound banks with lmms' builtin file explorer. I tried that with no luck -
> lmms would say the file is corrupted and tries to recover it.
This depends on whether you've the win32-version or the Linux version. For the
Linux-version you've to checkout LMMS-extras from SVN and compile them
separately (after installing LMMS). In the win32-version of 0.4.0-rc2 it's
already included. You just need to drag the ZynAddSubFX-plugin from the
instrument-browser (first tab on the left side) into Song-Editor.
Alternatively loading a XIZ-file in preset-browser by double-clicking or
clicking right and selecting according action should work too.

> Another way to load zynaddsubfx banks into lmms is to use the vst version,
> but I have no idea if I would succeed compiling it as a VST plugin - anyone
> succeeded with that?
There're only old VST plugins of ZynAddSubFX which also don't work that well.
I suggest using the built-in version which is compiled as native binary for
win32.

toby