I have recently installed lmms 0.3.0 from the debian binary, and I am unable to use the singerbot plugin.  AFAIK I have met the  dependencies, however trying to drag a singerbot instrument into my song results in a seg fault.  I have run lmms against gdb and got the following results.

Starting program: /usr/local/bin/lmms
Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread -1228351808 (LWP 4693)]
could not set realtime priority.
Qt: gdb: -nograb added to command-line options.
         Use the -dograb option to enforce grabbing.
Couldn't create MIDI-client, neither with ALSA nor with OSS. Will use dummy-MIDI-client.
[New Thread -1240671344 (LWP 4696)]
[New Thread -1249059952 (LWP 4697)]
[New Thread -1259340912 (LWP 4698)]

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1259340912 (LWP 4698)]
0xb681f9a2 in leval () from /usr/lib/libestools.so.1.2
(gdb) bt
#0  0xb681f9a2 in leval () from /usr/lib/libestools.so.1.2
#1  0xb682693e in vload () from /usr/lib/libestools.so.1.2
#2  0xb68af0cf in festival_load_default_files ()
   from /usr/local/lib/lmms/libsingerbot.so
#3  0xb68b0155 in festival_initialize ()
   from /usr/local/lib/lmms/libsingerbot.so
#4  0xb68ae17c in singerBot::synThread::run (this=0x8913880)
    at singerbot.cpp:405
#5  0xb79b0194 in QThreadInstance::start () from /usr/lib/libqt- mt.so.3
#6  0xb6e692d3 in start_thread () from /lib/libpthread.so.0
#7  0xb70c62fe in clone () from /lib/libc.so.6
(gdb) quit
The program is running.  Exit anyway? (y or n) y


Is the singerbot supposed to be working in this version or are these results to be expected?  Festival seems to run ok on my machine when I run it separately, as I believe I have up to date dev packages, however I cannot use the plugin in Lmms.

-Nathan