#495 Track Gets Huge Vertical Enlargement; Notes Randomly Vanish

Current Release
pending-fixed
Behavior (260)
5
2012-11-11
2012-11-10
Kris Koeckritz
No

Seems like a bizarre one to me, as there is no obvious trigger for either problem.
Basically, occasionally upon reloading a save, one of the tracks becomes abnormally vertically enlarged to what appears to be the size of the full note-range (see the attached image). Once this has happened, the track's notes still sound when the song is played in the song editor, but none of the track can be played from the piano roll, even though the notes still do show up there.
Up to this point, all the issues are merely annoyances. Things get worse when all the track's notes decide to disappear. The first time all this happened, I didn't notice until the notes were already gone; the second time, I watched the notes vanish while the song was playing.
So far, I've been unable to reproduce this at will, as the events truly seem to happen at random, but if I am able to soon I will post the steps in a comment.
Just to be thorough here, I'm still running Ubuntu 11.10, now two versions old. These problems have only started occurring since I updated LMMS (0.4.13-stable.git.2228-4~oneiric1 >> 0.4.13-stable.git.2240-1~11.10) (also: common, vst). Ideas?
Thanks!

Discussion

  • Kris Koeckritz
    Kris Koeckritz
    2012-11-10

    The Annoyance Stage

     
    Attachments

  • Anonymous
    2012-11-10

    Does this happen on loading an autosave or an explicitly saved project? Has there been another project opened previously in the same LMMS session?

    And... it would be pretty nice to have the problematic mmp(z) file to examine in addition to the screenshot.

     
  • Submitted a workaround as commit d3d6d658368ed547087f308e9a9c16c3b3b72c2c. Marking this bug as pending so we can work out a better solution. If not, the workaround will do as well.

     
    • assigned_to: nobody --> tobydox
    • status: open --> pending-fixed
     
  • Kris Koeckritz
    Kris Koeckritz
    2012-11-12

    Problem File

     
    Attachments
  • Kris Koeckritz
    Kris Koeckritz
    2012-11-12

    Just visited the commits, saw the workaround - hopefully the .mmpz (Attached!) can help with this. Happened when loading an explicitly saved project. I am fairly sure I had had another project open in the, then saved that, and loaded this one, in one session.