Learn how easy it is to sync an existing GitHub or Google Code repo to a SourceForge project! See Demo

Close

Standalone server

2010-01-26
2013-05-23
  • Cornu Nicolas
    Cornu Nicolas
    2010-01-26

    Hello,

    I have not compiled the server on my gentoo server. But i think it will not work cause I don't have X server on the server.
    Can you tell me if I am true. And if yes is there a simple solution to make it work.

    In advance thanks

    Nicolas Cornu

     
  • Cornu Nicolas
    Cornu Nicolas
    2010-01-26

    Just read that in another topic:

    nice -n -20 ./llcon -sn
    (this starts the server without using the GUI -> for use in SSH terminal)

     
  • Cornu Nicolas
    Cornu Nicolas
    2010-01-26

    QTWidget is needed even if we don't use the GUI ?

     
  • Cornu Nicolas
    Cornu Nicolas
    2010-01-26

    I mean QtGui

     
  • Cornu Nicolas
    Cornu Nicolas
    2010-01-26

    g++ -DHAVE_CONFIG_H -I. -I..    -I../src -I../libs/celt  -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml   -DQT_THREAD_SUPPORT -D_REENTRANT -g -g -O2 -MT llcon-buffer.o -MD -MP -MF .deps/llcon-buffer.Tpo -c -o llcon-buffer.o `test -f '../src/buffer.cpp' || echo './'`../src/buffer.cpp
    mv -f .deps/llcon-buffer.Tpo .deps/llcon-buffer.Po
    g++ -DHAVE_CONFIG_H -I. -I..    -I../src -I../libs/celt  -DQT_SHARED -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtNetwork -I/usr/include/qt4/QtXml   -DQT_THREAD_SUPPORT -D_REENTRANT -g -g -O2 -MT llcon-main.o -MD -MP -MF .deps/llcon-main.Tpo -c -o llcon-main.o `test -f '../src/main.cpp' || echo './'`../src/main.cpp
    In file included from ../src/client.h:42,
                     from ../src/llconclientdlg.h:37,
                     from ../src/main.cpp:30:
    ../src/../linux/sound.h: In destructor âvirtual CSound::~CSound()â:
    ../src/../linux/sound.h:86: erreur: âCloseâ was not declared in this scope
    make: ***  Erreur 1
    make: quittant le répertoire « /cyberdev/root-files/llcon/llcon-3.0.3/linux »
    make: ***  Erreur 2
    make: quittant le répertoire « /cyberdev/root-files/llcon/llcon-3.0.3/linux »
    make: ***  Erreur 1
    make: quittant le répertoire « /cyberdev/root-files/llcon/llcon-3.0.3 »

    I did comment
    Close() in CSound::~CSound()

     
  • Cornu Nicolas
    Cornu Nicolas
    2010-01-26

    The previous error is with configure -enable-sound=no

     
  • Volker Fischer
    Volker Fischer
    2010-01-26

    >  nice -n -20 ./llcon -sn

    This seems to be from an old thread. This is not working with the newest version of the llcon software. Use instead:
    nice -n -20 ./llcon -s -n

    > I did commentClose() in CSound::~CSound()

    This is a bug in the llcon software code. The call to the function "Close()" is wrong. Just delete it (as you already did). I'll fix this issue in the llcon cvs.

     
  • Volker Fischer
    Volker Fischer
    2010-01-26

    > QTWidget is needed even if we don't use the GUI ?
    > I mean QtGui

    Yes, it is required. QT is a fundamental library in the llcon software which cannot be omit, unfortunately.