New to Lives and rendering to .flv

2012-03-25
2012-09-15
  • Fred Hermanns
    Fred Hermanns
    2012-03-25

    Hello, I just started using lives and have a urgent question.

    How can I render to .flv format?

     
  • Salsaman
    Salsaman
    2012-03-25

    Quick answer: select ffmpeg_encoder and flv video codec.

    Longer answer: read the manual section on encoding first.

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-25

    Thank you. Had a look here:

    http://lives.sourceforge.net/manual/LiVES_manual.html#section4.9.1

    I set the target encoder tool preferences->encoding to:

    ffmpeg_encoder (finally found that) and flv

    Now when I change to clip mode->files encode clip as I choose the folder, the
    name, let lives set file type, etc. I the get this:

    ffmpeg_encoder command is: ffmpeg -comment "Created with LiVES" -author ""
    -title "" -y -r 25.000 -f image2 -i %8d.png -r 25.000 -t 753.44 -f flv
    "/Data/FintanGastro/Bodyforming/Video/Lives/bodyTest1.flv" 1>&2

    ffmpeg version 0.8.1-4:0.8.1-1really0u1, Copyright (c) 2000-2011 the Libav
    developers

    built on Mar 22 2012 23:56:58 with gcc 4.6.1

    This program is not developed anymore and is only provided for compatibility.
    Use avconv instead (see Changelog for the list of incompatible changes).

    Unrecognized option 'comment'

    Failed to set value 'Created with LiVES' for option 'comment'

    any ideas?

     
  • Salsaman
    Salsaman
    2012-03-25

    What version of LiVES ?

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-25

    1.4.6-1 0n Kubuntu 11.10 KDE 3.8.1

     
  • Salsaman
    Salsaman
    2012-03-25

    Well, that explains it. Upgrade to the latest release 1.6.1.

     
  • Salsaman
    Salsaman
    2012-03-26

    No idea, no. The decoder should recognise your version of ffmpeg and use
    -metadata comment=

    for some reason this is failing.

    If you type the following:

    ffmpeg 2>testfile

    grep libavcodec testfile | grep -v configuration

    you should find the version is 53 or higher. Otherwise you need to upgrade
    your ffmpeg.

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-26

    Okay, Upgraded using PPA above.

    Tried rendering again and get this:

    ffmpeg_encoder command is: ffmpeg -comment "Created with LiVES" -author ""
    -title "BodyTest" -y -r 25.000 -f image2 -i %8d.png -t 753.44 -f flv
    "/Data/FintanGastro/Bodyforming/Video/Lives/BodyTest.flv" 1>&2

    ffmpeg version 0.8.1-4:0.8.1-1really0u1, Copyright (c) 2000-2011 the Libav
    developers

    built on Mar 22 2012 23:56:58 with gcc 4.6.1

    This program is not developed anymore and is only provided for compatibility.
    Use avconv instead (see Changelog for the list of incompatible changes).

    Unrecognized option 'comment'

    Failed to set value 'Created with LiVES' for option 'comment'

    Tried this:

    ffmpeg 2>testfile

    grep libavcodec testfile | grep -v configuration

    and get:

    fintan@fintanws2:~$ ffmpeg 2>testfile

    Hyper fast Audio and Video encoder

    usage: ffmpeg [ -i infile]... { outfile}...

    fintan@fintanws2:~$ grep libavcodec testfile | grep -v configuration

    fintan@fintanws2:~$

    Confused !

     
  • Salsaman
    Salsaman
    2012-03-26

    Try with the ffmpeg from normal ubuntu. It works fine for me.

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-27

    He, He, not moving to ubuntu.

    ffmpeg works fine from the command line and from kdenlive.

    Wanted to use lives though, but before I spend hours on editing and inserting
    sound I want to sure I am able to render ;)

     
  • Salsaman
    Salsaman
    2012-03-27

    I wasnt suggesting you use the whole of ubuntu, just their version of ffmpeg,
    which is known to work.

    Alternately, just edit ffmpeg_encoder, and manually set the ffmpeg version to
    52., i.e.

    $ffver=52;

     
  • Salsaman
    Salsaman
    2012-03-27

    Or, maybe try this first:

    edit ffmpeg_encoder, change the line:

    ffmpeg 2>testfile;

    to:

    ffmpeg -version 2>testfile;

    might fix it, I dont know, it seems like kubuntu messed with ffmpeg output.

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-30

    Hmmm. That seems to work:

    fintan@fintanws2:~$ ffmpeg -version 2>testfile

    ffmpeg 0.8.1-4:0.8.1-1really0u1

    libavutil 51. 22. 1 / 51. 22. 1

    libavcodec 53. 35. 0 / 53. 35. 0

    libavformat 53. 21. 0 / 53. 21. 0

    libavdevice 53. 2. 0 / 53. 2. 0

    libavfilter 2. 15. 0 / 2. 15. 0

    libswscale 2. 1. 0 / 2. 1. 0

    libpostproc 52. 0. 0 / 52. 0. 0

    fintan@fintanws2:~$

    Is that helpful?

     
  • Salsaman
    Salsaman
    2012-03-30

    Yes very helpful.

    Please locate the file ffmpeg_encoder (probably in
    /usr/lib/lives/plugins/encoders/ or /usr/lib64/lives/plugins/encoders) on your
    system, and (as root) with a text editor, change the line:

    ffmpeg 2>testfile;

    to

    ffmpeg -version >testfile;

    This should fix the problem.

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-30

    Dis you mean this?

    if ($command eq "encode") {

    encode

    $encoder_command="ffmpeg";

    $ffver=ffmpeg 2>&1|grep libavformat | grep -v configuration;

    $ffver=(split(/./,$ffver));

    $ffver=(split(" ",$ffver));

    $usemp3=$ARGV;

    $usemp3lame=$ARGV;

    $nthreads=$ARGV;

    $vid_length=($end-$start+1)/$fps;

    $err=">/dev/null 2>&1";

    if (defined($DEBUG_ENCODERS)) {

    $err="1>&2";

    }

    To:

    if ($command eq "encode") {

    encode

    $encoder_command="ffmpeg";

    $ffver=ffmpeg -version>&1|grep libavformat | grep -v configuration;

    $ffver=(split(/./,$ffver));

    $ffver=(split(" ",$ffver));

    $usemp3=$ARGV;

    $usemp3lame=$ARGV;

    $nthreads=$ARGV;

    $vid_length=($end-$start+1)/$fps;

    $err=">/dev/null 2>&1";

    if (defined($DEBUG_ENCODERS)) {

    $err="1>&2";

    }

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-30

    Followup:

    Lives does not like the new ffmpeg_encoder file.

    Also I couldn't find this:

    "ffmpeg 2>testfile"

    in that file

     
  • Salsaman
    Salsaman
    2012-03-30

    Ah OK, the version you have is slightly different to what is in subversion.

    That is the correct line, you may change it as follows:

    $ffver=ffmpeg -version | grep libavformat | grep -v configuration;

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-30

    Changed the file as suggested. Srtill getting the same error. Going nuts ;)

     
  • Salsaman
    Salsaman
    2012-03-30

    Ah, I know what the problem is. I had to change it in subversion. This should
    fix it once and for all:

    if ($command eq "encode") {

    encode

    $encoder_command="ffmpeg";

    ffmpeg -version >testfile;

    $ffver=grep libavformat testfile | grep -v configuration;

    $ffver=(split(/./,$ffver));

    $ffver=(split(" ",$ffver));

    unlink "testfile";

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-31

    Okay, I'll try that.

    This is what this line looks like then:

    if ($command eq "encode") {

    encode

    $encoder_command="ffmpeg";

    ffmpeg -version >testfile;

    $ffver=grep libavformat testfile | grep -v configuration;

    $ffver=(split(/./,$ffver));

    $ffver=(split(" ",$ffver));

    unlink "testfile";

    $usemp3=$ARGV;

    $usemp3lame=$ARGV;

    $nthreads=$ARGV;

    $vid_length=($end-$start+1)/$fps;

    $err=">/dev/null 2>&1";

    if (defined($DEBUG_ENCODERS)) {

    $err="1>&2";

    }

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-31

    when I try that, lives does not see ffmpeg_encoder ?

     
  • Fred Hermanns
    Fred Hermanns
    2012-03-31

    Just to clarify, I get this message:

    The ffmpeg_encoder cannot encode clips with image type png.

    Please select another encoder from the list.

     
  • Peter
    Peter
    2012-09-08

    I've just installed LiVES on a fresh install of Ubuntu and I'm getting the
    same "Unrecognized option 'comment'

    Failed to set value 'Created with LiVES' for option 'comment'" error when
    trying to encode video.

    It's six months after this thread started, and this is STILL a bug... I know
    its the ffmpeg that's choking but, honestly, there should be more fault-
    tolerance than this. Having a conversion die because of something as trivial
    as metadata is poor for the 21st century. LiVES developers, PLEASE take out
    your comment and save us the aggravation...