Unable to load video from camera

2010-12-07
2012-09-15
  • Mark Phillips
    Mark Phillips
    2010-12-07

    I am running on Debian testing, amd64. I installed Lives from the Debian
    repositories (not Debian multimedia as it says on the web page) and have
    version 1.3.4 running. When I try to grab DV from my camera, the camera
    starts, plays video, no error messages appear, but no files are saved. I then
    tried running dvgrab from the command line and got this output. Again , the
    camera starts and displays video in the camera screen.

    orca:/home/mark/Movies/Savage/clips# dvgrab -f dv2 foo-
    Found AV/C device with GUID 0x0800460102561c47
    Waiting for DV...
    
    "": damaged frame near: timecode ??:??:??.?? date ????.??.?? ??:??:??
    This means that there were missing or invalid FireWire packets.
    

    ......quite a few of these as the camera starts and comes up to speed. Once
    the camera is up to speed, they stop. I assume (perhaps incorrectly?) that
    these are just due to the camera motor coming up to speed. After running for a
    minute and no error messages I hit ctrl-C and get this:

    ^C"":     0.00 MiB 0 frames timecode 00:00:00.00 date 2010.12.05 09:10:52
    Capture Stopped
    Warning: 151 damaged frames.
    

    The same happens if I run as a normal user. Occasionally, as a normal user or
    root, I get a segmentation fault. I have dvgrab version 3.5 installed.

    Is there another program that I can use to grab DV from my camera over
    firewire? Any ideas on how to get dvgrab to work?

    Thanks,

    Mark

     
  • Salsaman
    Salsaman
    2010-12-07

    Hi Mark,

    not sure what the problem is there. You should probably ask the

    dvgrab/kino developers, they might be able to help you. At a guess though,

    if you are getting a lot of damaged frames it might be that your machine

    is too slow to encode the video. Try -f raw.

    Regards,

    Gabriel.

     
  • Mark Phillips
    Mark Phillips
    2010-12-07

    I tried -f raw and got the same results - no output file and the same errors.
    The errors go away when the camera is running; they only occur as dvgrab first
    turns on the camera. Once the camera is running and the video is playing in
    the view finder, the errors stop.

    The forum on the Kino web site is dead - locked for read only. The notice
    implies that no one is active on the project (http://www.kinodv.org/dcforum/d
    cforum?az=show_topics&forum=100).
    I can't find an email list for dvgrab, so I don't
    have a way to contact anyone on that project. I guess it is dead, too. That is
    why I asked if there is another way to grab DV from a camera over firewire.

    At this point I am stuck - no DV support on Linux! :-(

    Mark