Unable to load any video

2010-01-05
2012-09-15
1 2 > >> (Page 1 of 2)
  • Lars Kühne
    Lars Kühne
    2010-01-05

    Hello,

    when I try to load an arbitrary video file the console of LIVES prints the
    following message:

    Playback speed not found or invalid ! Using default fps of 25.000 fps.

    The audio stream is played correctly. But below the timeline it displays "no
    video".

    I'm using version 1.1.8 which i I compiled from source, on and AMD64 linux
    machine. After start the console displays the following:

    `Checking optional dependencies:mplayer...detected...convert...detected...comp
    osite...detected...sox...detected

    xmms...NOT DETECTED...cdda2wav...detected...jackd...NOT DETECTED...pulse
    audio...detected...python...detected...dvgrab...NOT
    DETECTED...xwininfo...detected...`

    The only thing I found on Google about this was a suspect on a problem with
    mplayer. I tried to play the video external with mplayer and it worked. So
    that doesn't seem to be the problem.

    I hope you can help.

     
  • Salsaman
    Salsaman
    2010-01-05

    Hi, can you type the following in a terminal, where is the full path of any
    video file:

    mplayer -identify -vo null -ao null -frames 0

    Then please copy the output from mplayer and paste it here.

    Also check that you have mplayer compiled with png support;

    mplayer -vo help

    should list png as one of the supported formats.

     
  • Lars Kühne
    Lars Kühne
    2010-01-05

    Hi,

    and thanks for your response so far. The first command brought me this output:


    MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team

    CPU: Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz (Family: 6, Model: 23,
    Stepping: 6)

    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

    Compiled with runtime CPU detection.

    mplayer: could not connect to socket

    mplayer: No such file or directory

    Failed to open LIRC support. You will not be able to use your remote control.

    Playing Videos/funnyMovie.flv.

    libavformat file format detected.

    ID_VIDEO_ID=0

    Video stream found, -vid 0

    ID_AUDIO_ID=1

    Audio stream found, -aid 1

    VIDEO: 720x480 0bpp 29.917 fps 0.0 kbps ( 0.0 kbyte/s)

    ID_FILENAME=Videos/funnyMovie.flv

    ID_DEMUXER=lavfpref

    ID_VIDEO_FORMAT=VP6F

    ID_VIDEO_BITRATE=0

    ID_VIDEO_WIDTH=720

    ID_VIDEO_HEIGHT=480

    ID_VIDEO_FPS=29.917

    ID_VIDEO_ASPECT=0.0000

    ID_AUDIO_FORMAT=85

    ID_AUDIO_BITRATE=32000

    ID_AUDIO_RATE=22050

    ID_AUDIO_NCH=2

    ID_LENGTH=138.07

    ==========================================================================

    Opening video decoder: FFmpeg's libavcodec codec family

    Selected video codec: vfm: ffmpeg (FFmpeg VP6 Flash decoder)

    ==========================================================================

    ID_VIDEO_CODEC=ffvp6f

    ==========================================================================

    Forced audio codec: mad

    Opening audio decoder: libmad mpeg audio decoder

    AUDIO: 22050 Hz, 2 ch, s16le, 32.0 kbit/4.54% (ratio: 4000->88200)

    ID_AUDIO_BITRATE=32000

    ID_AUDIO_RATE=22050

    ID_AUDIO_NCH=2

    Selected audio codec: afm: libmad (libMAD MPEG layer 1-2-3)

    ==========================================================================

    AO: 22050Hz 2ch s16le (2 bytes per sample)

    ID_AUDIO_CODEC=mad

    Starting playback...

    Exiting... (End of file)


    The second command verified, that i have png support with my version of
    mplayer, as it was listed in the output.

    What does that mean for me now?

    PS: Sry for the strange output her, but the code environment didn't work with
    it

     
  • Salsaman
    Salsaman
    2010-01-05

    I can't see anything yet which would cause a problem.

    Can you edit the file /usr/bin/smogrify with a text editor (you might need to
    use sudo). Near the start of the file, add the following line:

    $DEBUG_OPEN=1;

    then save the file.

    Now start LiVES from a terminal:

    lives

    then try to open the video again. You should now see something like:

    open command for ... is:

    Please copy that line and paste it here.

     
  • Lars Kühne
    Lars Kühne
    2010-01-05

    Thanks for your patience!

    I followed your advice and opened the file again. The console gave me this:

    open command for 692787377 is: LANGUAGE=en LANG=en /usr/bin/mplayer
    -quiet -osdlevel 0 -vo png:z=0:alpha-noframedrop -ao pcm:fast:nowaveheader
    -channels 2 -mc 0 "/home/username/Videos/funnyVideo.flv" </dev>
    
    Hope this helps you to help me ;)
    
    
    
     
  • Salsaman
    Salsaman
    2010-01-05

    There should a space between alpha and -noframedrop. Can you confirm that ?

    Assuming the space is there, you can now try the following - create a test
    directory:

    mkdir testdir

    cd testdir

    then try the command typing it in like:

    LANGUAGE=en LANG=en /usr/bin/mplayer -quiet -osdlevel 0 -vo png:z=0:alpha
    -noframedrop -ao pcm:fast:nowaveheader -channels 2 -mc 0
    "/home/username/Videos/funnyVideo.flv"

    You should see a load of png files and an audiodump.wav file.

    Otherwise you might see an error message.

     
  • Salsaman
    Salsaman
    2010-01-05

    Sorry, this thing has a tendency to break formatting, that should be:

    mkdir testdir

    cd testdir

     
  • Lars Kühne
    Lars Kühne
    2010-01-06

    I confirm that there is a space between the "alpha" and the "-noframedrop".
    Dunno how it got lost.

    I issued the command as posted and got the following result:

    MPlayer 1.0rc2-4.3.3 (C) 2000-2007 MPlayer Team

    CPU: Intel(R) Core(TM)2 Duo CPU E8200 @ 2.66GHz (Family: 6, Model: 23,
    Stepping: 6)

    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1

    Compiled with runtime CPU detection.

    mplayer: could not connect to socket

    mplayer: No such file or directory

    Failed to open LIRC support. You will not be able to use your remote control.

    Playing ../Videos/funnyVideo.flv.

    libavformat file format detected.

    Video stream found, -vid 0

    Audio stream found, -aid 1

    VIDEO: 720x480 0bpp 29.917 fps 0.0 kbps ( 0.0 kbyte/s)

    Could not parse arguments at the position indicated below:

    z=0:alpha (inserted by me: a "hat" pointing to the beginning of "alpha" I had
    to remove because of formatting here)


    Error opening/initializing the selected video_out (-vo) device.

    ==========================================================================

    Forced audio codec: mad

    Opening audio decoder: libmad mpeg audio decoder

    AUDIO: 22050 Hz, 2 ch, s16le, 32.0 kbit/4.54% (ratio: 4000->88200)

    Selected audio codec: afm: libmad (libMAD MPEG layer 1-2-3)

    ==========================================================================

    File: audiodump.pcm (RAW PCM)

    PCM: Samplerate: 22050Hz Channels: Stereo Format s16le

    Info: Faster dumping is achieved with -vc null -vo null -ao pcm:fast

    Info: To write WAVE files use -ao pcm:waveheader (default).

    AO: 22050Hz 2ch s16le (2 bytes per sample)

    Video: no video

    Starting playback...

    Cannot sync MAD frame

    Cannot sync MAD frame

    Cannot sync MAD frame

    Cannot sync MAD frame

    Exiting... (End of file)


    After this, the directory contains a file "audiodump.pcm" which is unplayable.

    Seems like the mplayer doesn't know about this argument. Do I have to use a
    newer version? I got mine through the ubuntu repos.

     
  • Salsaman
    Salsaman
    2010-01-06

    OK, it seems like the "alpha" is what is causing the problem. It works fine
    for me with the version of mplayer in ubuntu 9.10, so maybe you need to update
    your mplayer as you suggest.

    An alternative would be to change the setting in Preferences -> Decoding, and
    select a default image type of "jpeg" instead of "png".

    Hope this resolves the issue for you.

     
  • Lars Kühne
    Lars Kühne
    2010-01-06

    thank you,

    switching from png to jpeg in the preferences got it to work. I don't know
    what that means for the performance, but i'm glad it works now. I think I'm
    gonna compile mplayer from source instead of using the ubuntu package that i'm
    using right now to get the png support working.

    Big thanks for your help! :)

     

  • Anonymous
    2011-05-16

    I'm getting the same problem on Ubuntu 11.04. My videos are created using a
    ContourHD camera. Video specs are 1280x960 H.264/AVC 30 frame per second.

    I ran the commands suggested above, but didn't manage to get things working.

    mplayer -vo help lists png as one of the formats.

    > mplayer -identify -vo null -ao null -frames 0 *48*
    MPlayer 1.0rc4-4.5.2 (C) 2000-2010 MPlayer Team

    mplayer: could not connect to socket

    mplayer: No such file or directory

    Failed to open LIRC support. You will not be able to use your remote control.

    Playing FILE0048.MOV.

    libavformat file format detected.

    ID_VIDEO_ID=0

    stream 0: video (h264), -vid 0

    ID_AUDIO_ID=0

    ID_AID_0_LANG=eng

    stream 1: audio (aac), -aid 0, -alang eng

    VIDEO: 1280x960 24bpp 29.970 fps 7276.9 kbps (888.3 kbyte/s)

    Clip info:

    major_brand: qt

    ID_CLIP_INFO_NAME0=major_brand

    ID_CLIP_INFO_VALUE0=qt

    minor_version: 0

    ID_CLIP_INFO_NAME1=minor_version

    ID_CLIP_INFO_VALUE1=0

    compatible_brands: qt

    ID_CLIP_INFO_NAME2=compatible_brands

    ID_CLIP_INFO_VALUE2=qt

    ID_CLIP_INFO_N=3

    ID_FILENAME=FILE0048.MOV

    ID_DEMUXER=lavfpref

    ID_VIDEO_FORMAT=H264

    ID_VIDEO_BITRATE=7276912

    ID_VIDEO_WIDTH=1280

    ID_VIDEO_HEIGHT=960

    ID_VIDEO_FPS=29.970

    ID_VIDEO_ASPECT=1.3333

    ID_AUDIO_FORMAT=MP4A

    ID_AUDIO_BITRATE=128000

    ID_AUDIO_RATE=48000

    ID_AUDIO_NCH=2

    ID_START_TIME=0.00

    ID_LENGTH=9.91

    ID_SEEKABLE=1

    ID_CHAPTERS=0

    ==========================================================================

    Opening video decoder: FFmpeg's libavcodec codec family

    Selected video codec: vfm: ffmpeg (FFmpeg H.264)

    ==========================================================================

    ID_VIDEO_CODEC=ffh264

    ==========================================================================

    Opening audio decoder: AAC (MPEG2/4 Advanced Audio Coding)

    AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)

    ID_AUDIO_BITRATE=128000

    ID_AUDIO_RATE=48000

    ID_AUDIO_NCH=2

    Selected audio codec: afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio))

    ==========================================================================

    AO: 48000Hz 2ch s16le (2 bytes per sample)

    ID_AUDIO_CODEC=faad

    Starting playback...

    Exiting... (End of file)

    ID_EXIT=EOF

    lives

    Xlib: extension "RANDR" missing on display ":0".

    LiVES 1.4.1

    Copyright 2002-2010 Gabriel Finch (salsaman@xs4all.nl) and others.

    LiVES comes with ABSOLUTELY NO WARRANTY

    This is free software, and you are welcome to redistribute it

    under certain conditions; see the file COPYING for details.

    open command for 923913276 is: LANGUAGE=en LANG=en /usr/bin/mplayer -quiet
    -osdlevel 0 -vo jpeg:quality=85 -lavdopts o=threads=2 -noframedrop -ao
    pcm:fast:no" </dev/nullmc 0 "/home/brendan/Desktop/FILE0048.MOV

    Can you give me some suggestions of what to try? I tried changing to jpeg but
    that did not solve the problem.

     
  • Salsaman
    Salsaman
    2011-05-16

    That command you cut and paste looks a bit wrong, it should be something like:

    LANGUAGE=en LANG=en /usr/bin/mplayer -quiet -osdlevel 0 -vo jpeg:quality=85
    -lavdopts o=threads=2 -noframedrop -ao pcm:fast:nowaveheader -mc 0
    "/home/brendan/Desktop/FILE0048.MOV" < /dev/null

    Assuming this is just a transcription error, you can try something like:

    create an empty directory in your home:

    mkdir /home/brendan/test123 && cd /home/brendan/test123

    then try entering the command manually:

    LANGUAGE=en LANG=en /usr/bin/mplayer -quiet -osdlevel 0 -vo jpeg:quality=85
    -lavdopts o=threads=2 -noframedrop -ao pcm:fast:nowaveheader -mc 0
    "/home/brendan/Desktop/FILE0048.MOV" < /dev/null

    this should show up any errors which are output.

     
  • John
    John
    2011-12-23

    same problem this is what I got

    MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team

    mplayer: could not connect to socket

    mplayer: No such file or directory

    Failed to open LIRC support. You will not be able to use your remote control.

    Playing /home/john/Desktop/Default Project.mpeg.

    MPEG-PS file format detected.

    VIDEO: MPEG2 640x480 (aspect 1) 29.970 fps 0.0 kbps ( 0.0 kbyte/s)

    Load subtitles in /home/john/Desktop/

    jpeg: Progressive JPEG disabled.

    jpeg: Baseline JPEG enabled.

    ==========================================================================

    Opening video decoder: FFmpeg's libavcodec codec family

    Selected video codec: vfm: ffmpeg (FFmpeg MPEG-2)

    ==========================================================================

    ==========================================================================

    Requested audio codec family (afm=mpg123) not available.

    Enable it at compilation.

    Opening audio decoder: FFmpeg/libavcodec audio decoders

    AUDIO: 44100 Hz, 2 ch, floatle, 256.0 kbit/9.07% (ratio: 32000->352800)

    Selected audio codec: afm: ffmpeg (FFmpeg MPEG layer-1 and layer-2 audio)

    ==========================================================================

    File: audiodump.pcm (RAW PCM)

    PCM: Samplerate: 44100Hz Channels: Stereo Format floatle

    Info: Faster dumping is achieved with -benchmark -vc null -vo null -ao
    pcm:fast

    Info: To write WAVE files use -ao pcm:waveheader (default).

    AO: 44100Hz 2ch floatle (4 bytes per sample)

    Starting playback...

    Header missing

    Unsupported PixelFormat 61

    Unsupported PixelFormat 53

    Could not find matching colorspace - retrying with -vf scale...

    Opening video filter:

    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.

    using unscaled yuv420p -> rgb24 special converter

    VO: 640x480 => 640x480 RGB 24-bit

    jpeg: . - Output directory already exists and is writable.

    Exiting... (End of file)

     
  • Salsaman
    Salsaman
    2011-12-23

    Try running Help -> Troubleshoot

    it should tell you if anything important is missing.

     
  • John
    John
    2011-12-23

    Everything passed

     
  • Salsaman
    Salsaman
    2011-12-24

    Well, it boils down to one of 3 possibilities:

    • mplayer cannot play the file in question
    • the decoding options passed to mplayer cause it to give an error
    • mplayer is not able to produce the required output (jpeg or png)

    There should be enough information in this thread to figure out which of the 3
    cases it is.

     
  • Salsaman
    Salsaman
    2011-12-24

    If you can try attaching a very small sample clip it would also be helpful.

     
  • John
    John
    2011-12-25

    im getting the same error no mater what type of file I try importing (.jpg,
    mov, mp4 others )

     
  • Salsaman
    Salsaman
    2011-12-25

    OK lets take this step by step.

    1) Are you able to play these files in mplayer ?

    2) If so, what is the error message you are getting in LiVES ?

    3) What is the mplayer command which LiVES is running to try to decode a file
    ?

    4) When you run this same command from a terminal do you see any errors being
    produced ? Do you see any image files being generated ?

     
  • John
    John
    2011-12-25

    1. Look at comment 13 is that what you are looking for

    2.This does not appear to be a valid video or image file

    LiVES was unable to open it.

    3./usr/bin/mplayer

     
  • John
    John
    2011-12-25

    1.>

    john@john-HP-Compaq-dc7600-Convertible-Minitower:~$ LANGUAGE=en LANG=en
    /usr/bin/mplayer -quiet -osdlevel 0 -vo jpeg:quality=85 -lavdopts o=threads=2
    -noframedrop -ao pcm:fast:nowaveheader -mc 0 "/home/john/Desktop/Default
    Project.mpeg" < /dev/null

    MPlayer SVN-r33713-4.6.1 (C) 2000-2011 MPlayer Team

    mplayer: could not connect to socket

    mplayer: No such file or directory

    Failed to open LIRC support. You will not be able to use your remote control.

    Playing /home/john/Desktop/Default Project.mpeg.

    MPEG-PS file format detected.

    VIDEO: MPEG2 640x480 (aspect 1) 29.970 fps 0.0 kbps ( 0.0 kbyte/s)

    Load subtitles in /home/john/Desktop/

    jpeg: Progressive JPEG disabled.

    jpeg: Baseline JPEG enabled.

    ==========================================================================

    Opening video decoder: FFmpeg's libavcodec codec family

    Selected video codec: vfm: ffmpeg (FFmpeg MPEG-2)

    ==========================================================================

    ==========================================================================

    Requested audio codec family (afm=mpg123) not available.

    Enable it at compilation.

    Opening audio decoder: FFmpeg/libavcodec audio decoders

    AUDIO: 44100 Hz, 2 ch, floatle, 256.0 kbit/9.07% (ratio: 32000->352800)

    Selected audio codec: afm: ffmpeg (FFmpeg MPEG layer-1 and layer-2 audio)

    ==========================================================================

    File: audiodump.pcm (RAW PCM)

    PCM: Samplerate: 44100Hz Channels: Stereo Format floatle

    Info: Faster dumping is achieved with -benchmark -vc null -vo null -ao
    pcm:fast

    Info: To write WAVE files use -ao pcm:waveheader (default).

    AO: 44100Hz 2ch floatle (4 bytes per sample)

    Starting playback...

    Header missing

    Unsupported PixelFormat 61

    Unsupported PixelFormat 53

    Could not find matching colorspace - retrying with -vf scale...

    Opening video filter:

    Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.

    using unscaled yuv420p -> rgb24 special converter

    VO: 640x480 => 640x480 RGB 24-bit

    jpeg: . - Output directory already exists and is writable.

    Exiting... (End of file)

     
  • Salsaman
    Salsaman
    2011-12-26

    OK, so then try this:

    cd /home/john/

    mkdir testimgs

    cd testimgs

    LANGUAGE=en LANG=en /usr/bin/mplayer -quiet -osdlevel 0 -vo jpeg:quality=85
    -lavdopts o=threads=2 -noframedrop -ao pcm:fast:nowaveheader -mc 0
    "/home/john/Desktop/Default Project.mpeg" < /dev/null

    Then you should see a load of jpegs being generated, and possibly an audio
    file. If not then most likely you do not have mplayer compiled with jpeg or
    png output support.

    .

     
  • Salsaman
    Salsaman
    2011-12-26

    It's also possible you just got a bad build of mplayer; the version I have
    here is SVN-r33996-4.6.1 and it works fine for mpeg2 and other formats
    decoding to images.

     
  • John
    John
    2011-12-26

    when I use this mplayer "/home/john/Desktop/Default Project.mpeg" the clip
    plays just fine

     
  • John
    John
    2011-12-26

    Mplayer created .jpg in the test dir

     
1 2 > >> (Page 1 of 2)