Unable to import individual JPEG pictures

  • I am attempting to import a number of JPEG images into Lives and get the
    following error in the console for each file that Lives tries to open:

    Failed to open file - I tried:
     LANGUAGE=en LANG=en /usr/bin/mplayer -quiet  -osdlevel 0 -vo jpeg:quality=85  -noframedrop  -ao pcm:fast:nowaveheader  -mc 0  "/home/langdons/Pictures/walking/IMG_0021.JPG"  </dev/null
    Maybe you are missing a library in mplayer (or it is not a valid media file) ?

    Lives previews the files properly before import.

    If I run the command that Lives lists directly through Mplayer I get the

    mplayer -osdlevel 0 -vo jpeg:quality=85 -noframedrop -ao pcm:fast:nowaveheader -mc 0 IMG_0451.JPG 
    MPlayer SVN-r28461-4.3.2 (C) 2000-2009 MPlayer Team
    CPU: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.
    Playing IMG_0451.JPG.
    libavformat file format detected.
    [mp3 @ 0x984a510]Could not find codec parameters (Audio: mp1, 0 channels, s16)
    LAVF_header: av_find_stream_info() failed
    Exiting... (End of file)

    I have checked that mplayer has jpeg support, which looks like it does:

    mplayer -vo help
    mplayer -vo help
    MPlayer SVN-r28461-4.3.2 (C) 2000-2009 MPlayer Team
    CPU: Intel(R) Core(TM)2 CPU          6600  @ 2.40GHz (Family: 6, Model: 15, Stepping: 6)
    Available video output drivers:
        xv  X11/Xv
        x11 X11 ( XImage/Shm )
        xover   General X11 driver for overlay capable video output drivers
        gl  X11 (OpenGL)
        gl2 X11 (OpenGL) - multiple textures version
        dga DGA ( Direct Graphic Access V2.0 )
        sdl SDL YUV/RGB/BGR renderer (SDL v1.1.7+ only!)
        fbdev   Framebuffer Device
        fbdev2  Framebuffer Device
        aa  AAlib
        caca    libcaca
        dxr3    DXR3/H+ video out
        v4l2    V4L2 MPEG Video Decoder Output
        xvidix  X11 (VIDIX)
        cvidix  console VIDIX
        null    Null video output
        xvmc    XVideo Motion Compensation
        mpegpes MPEG-PES to DVB card
        yuv4mpeg    yuv4mpeg output for mjpegtools
        png PNG file
        jpeg    JPEG file
        gif89a  animated GIF output
        tga Targa output
        pnm PPM/PGM/PGMYUV file
        md5sum  md5sum of each frame

    I am also able to use mplayer to play the string of JPEGs directly, so it is
    definitely able to open and display jpeg files.

    Any suggestions about how to debug this issue would be greatly appreciated.

  • Salsaman


    yes it seems there is a bug in LiVES 1.1.8. You can fix this quite easily:

    edit /usr/bin/smogrify, and around line 4300, there should be a line like:

    my $conv_cmd=$convert_command;

    change this to:

    my $conv_command=$convert_command;

    and it should fix the problem.

  • Hi gfinch,

    Thanks for your fast feedback, that fixed the problem 100%. I am now importing
    JPEGs happily.