#109 Lives-1.0.4 crashes on initial load of libvis.so

generic
closed
Salsaman
plugins (11)
9
2012-09-15
2009-10-19
Moritz Barsnick
No

My self-compiled lives-1.0.4 never brings up the GUI properly, it crashes on loading libvis.so. Removal of libvis.so remedies this particular problem.
(Now I'm stuck at "starting jack audio server", but that may be due to me working in an NX session.)

gdb output and backtrace is attached.

With lives-1.0.3, it just works. Furthermore, 1.0.3 warns me about jack hindering the start of lives on some systems and lets me choose sox instead. If I select sox, the program properly appears.

Discussion

  • gdb backtrace of crash on load of libvis.so

     
  • Actually, version 1.0.3 just says
    error loading plugin /usr/lib//lives/plugins/effects/realtime/weed/libvis.so
    before starting to work. Much more desirable behavior.

     
  • Salsaman
    Salsaman
    2009-10-19

    Regarding the second part of , I recommend you switch to the newer pulse audio player in Preferences -> Playback. (available in LiVES 1.1.4).

     
  • I can confirm (although it was hard to find the corresponding thread due to broken threading):
    The attached patch (for reference) fixes this issue. Looking forward to 1.0.5/1.1.5.

    BTW, I hadn't used 1.1.4 vs. 1.0.4 because 1.0.4 is marked "stable". Not that I usually care. ;-)

    Thanks for the quick fix.

     
  • Salsaman
    Salsaman
    2009-10-20

    Keeping bug open (fixed) in case others have this problem.

    Will close after next release.

     
  • Salsaman
    Salsaman
    2009-10-27

    Fixed in 1.1.5 and 1.0.5